Unable to change selection in Additional Drivers. Recent Nvidia update perhaps the cause?

Hi, regrettably my first post in this community is one asking for help. :slight_smile: To get to the point, I can’t switch my Additional Drivers from the X.Org X Server Nouveau open source selection to an Nvidia Proprietary one. I’m using an Nvidia GTX 750 Ti card.

I believe the cause may be related somewhat to what’s discussed in this post here from the forum, but I’m not exactly 100% sure, and would not rather assume.

Far as I can tell, I updated my system today, and two things did not update properly. The packages failed, and I am pretty certain they were nvidia-opencl-icd-364 and libcuda1-364. I tried a few things before finally decided to come here (And I am rather thankful I recently did a file back up just in case I’m up a creek here, or get that way ):

  1. First I used the Software Boutique to try to fix broken/interrupted packages. Didn’t help, still got the same error, and my system updater tried to get me to download those same packages which said were already downloaded.

  2. Thinking maybe if I removed the PPA that you can optionally install in the Welcome screen for more Nvidia drivers ( ppa:graphics-drivers/ppa) and redo the system update would help it somehow, along with choosing the “best” possible server to download updates from instead of the US main. Eh, flawed logic I suppose. Didn’t work either.

  3. Reading various things on google, and then coming to this forum and reading the linked topic above, this might be my issue. But again I’m not sure, though I did try removing the packages through synaptic as that was met with some success by lah7. Synaptic fails to remove the packages for some reason that I can’t grasp, despite being on the main account and all of the computer. I haven’t quite yet tried the other methods in that thread yet, as I’ve seen it requires a networking cable, and it’s rather difficult for me to lug my computer from where I am, to where the modem/router is up a flight of stairs to plug it in. However, if it truly comes down to that, I’ll give it a shot when I’m able. I’d just figure I’d get the opinion, thoughts, and so on of other people that’ll probably know better than me before I make a serious user error.

Any assistance with this issue would be most welcome please, and I’d be very thankful.

Hi @glgamer ,

I can really only recommend you remove what drivers you have in recovery mode and install the "nvidia-361" package (also in recovery mode) and don't use the Nvidia PPA!:

1 Like

It sounds like you did run into the same problem I did… two stubborn packages that won’t remove. It’s like receiving something in the post/mail to find it was already broken. :package: :confounded:

This same behaviour happened in the Additional Drivers menu, where it would not allow me to use another driver until I purged the problematic packages. Afterwards I was able to install a different version (this time 367, not 364)

I’d avoid 364 until the packaging issue is solved. Re-installing it again will lead to the problem all over again. If you’d prefer stability over new stuff, remove the PPA and use the one in Ubuntu’s repositories, as @wolfman suggests.

It was a surprise to me when I purged nvidia-opencl-icd-364 and libcuda1-364 in Synaptic, this just worked after rebooting the computer. You could attempt this in recovery mode, by holding SHIFT before Ubuntu MATE starts loading.

You wouldn’t as such need a network cable – just to successfully remove these bad packages, reboot, and then the Additional Drivers should start working again:

sudo apt remove --purge nvidia-opencl-icd-364 libcuda1-364

**If that didn't work, try these solutions.** http://askubuntu.com/questions/525088/how-to-delete-broken-packages-in-ubuntu http://askubuntu.com/questions/438345/how-to-remove-install-a-package-that-is-not-fully-installed http://askubuntu.com/questions/167991/how-to-force-remove-a-package-if-dpkg-removal-script-fails
1 Like

Thank you wolfman, very much. As much as I’d like to say I used that method to fix my problem, it got far too late at night for me to lug my computer upstairs to the room that has the router where I could plug it in with the network cable :slight_smile:

I did do some deeper digging after a short while of relaxing, and manage to fix the problem finally, though probably not necessarily in a recommended, more easy way. It essentially had the same results though, with purging/removing the nvidia drivers and such through the terminal completely, and reinstalling them. Even with the other instructions I found, I did slightly muddle a bit I have to admit, but fortunately I don’t think I messed up anything or deviated too far. I could rehash what I did here if it helps anyone else, but I think I’d rather recommend what you offered!

1 Like

(Not sure if this would count as a double-post or a type of spam since I’m replying to you lah7, so forgive me if it does and I’ll make sure not to repeat it!)

Yep lah7, that’s pretty much what happened to me! And that sounds like what I ended up doing in the long run, only more summed up and less involved. God forbid, if that ever happens again (and this may have happened to another computer in the house, so…) I’ll try that fix. The fact that I wouldn’t need a network cable just to remove the bad packages only would be load off my mind, and my arms in carrying some heavy desktops around! I think once I check the other PC to make sure it doesn’t need this fix (hopefully), I’ll keep both off the Nvidia PPA for the gpus from now on.

Thank you both for your replies :slight_smile:

1 Like