Unfortunately, I no longer use Ubuntu MATE

After using Arch Linux for two years, I finally thought I had found an Ubuntu distro worth using. I was tired of the breakages in Arch Linux that required user invention, and I decided that I just wanted something that was stable.
Initially, I was extremely excited about the release of Ubuntu MATE 16.04. Martin Wimpress and his team really know what they are doing when it comes to listening to the community and fulfilling the vision of a retrospective future. Some of the most prominent Linux bloggers have vouched for this distro’s unique combination of innovation and stability. Ubuntu MATE Welcome, TLP and Compiz are great examples of how the Ubuntu MATE team have gone above and beyond what is expected from an Ubuntu flavor.

Unfortunately, Ubuntu MATE has inherited many bad things from being a part of the Ubuntu family as well, and consequently using Ubuntu MATE 16.04 turned out to be an exhausting waste of time. It would be very easy for me to just turn my back on this whole experience and forget about it completely, but I think that would be selfish. Instead, I want to share some feedback so the distribution can continue to be improved for everyone. I’ll share the 4 most crippling issues when I used Ubuntu MATE 16.04, in from least frustrating to most frustrating:

4. Synapse segfaults a lot
I’ve really enjoyed using Synapse on other distros, and even on Arch Linux I found it to be extremely stable. So I was surprised when I found that on Ubuntu MATE 16.04 synapse couldn’t stop crashing. I would open it, type a key, and the window would disappear. Absolutely useless. Out of the four issues, though, I managed to fix this one. I Googled around for a bit, then changed something with the input method, and the problem went away. To me this seems like a misconfiguration on Canonical’s part of IBus, but I’m not super familiar with that infrastructure. A normal user shouldn’t be expected to know how to do this, but I managed to fix it (I don’t remember how, just Google around). :sweat:

3. Ubuntu Update Manager is completely broken
One of the things that brought me from the Arch camp to Ubuntu MATE is that on an Ubuntu-based system the Update Manager will make sure that you get security updates on time, which makes system administration much easier. The Update Manager is supposed to pop up and tell you when updates are available, give you the option to install them, you type in your password, and then you continue on your merry way. Oh, and it will also tell you if you need to reboot after the updates are installed, which was always confusing for me when I used Arch. Ridicule me all you want, but this is the kind of hand-holding that I expect from a modern operating system. Instead, the Update Manager would show up in the taskbar, I would try to click on it and no window would pop up. When I tried to run the Update Manager from the command line it would spit out some information about a Python bug and not run at all. This came broken out of the box, and I couldn’t find anyway to fix this. I expect this is Canonical’s fault, and not the fault of the Ubuntu MATE team. Still, it ruined my experience. :cry:

2. Unless I used the Ubuntu MATE panel layout, my panels would be frozen when I logged in
I definitely prefer the Redmond layout. I’ve tried using the default one, but we just don’t get along. This is supposed to be one of the great things about Ubuntu MATE though. The Tweak tool makes it really easy to use other panel layouts. However when I logged in, my panel would first appear at the top of the screen, then jump down to to the bottom of the screen. After the panel finally found it’s resting place, all the items were frozen and could not be clicked on at all. My workaround ended up being launching Firefox from a keyboard shortcut, clicking on the Firefox titlebar, minimizing Firefox, alt-tabbing back to Firefox and usually some kind of jig like that would un-freeze the panels. Begrudgingly, I switched back to the default layout. :confounded:

1. Wireless networking is completely and utterly broken
This was definitely the worst issue. Wireless networking only worked without some kind of struggle about half the time, and the wrong wireless connectivity icon was displayed in the tray close to all the time. I have a Realtek RTL8188EE. I don’t think it’s just the kernel. I’ve run Arch Linux with the same kernel and it didn’t have these issues, so maybe Ubuntu has a broken implementation of NetworkManager as well. I know I’m not the only person with this issue. Dedoimedo reported a similar finding in both his review of Ubuntu and Xubuntu and I expect when he reviews Ubuntu MATE he’ll have the same harsh words for Ubuntu MATE as well. Also, Joe Collins from Freedom Penguin has reported on some of these issues as well..

Joe Collins’ conclusion was to switch to Linux Mint, and ultimately that is what I ended up doing as well. I haven’t even touched on some of the other things, like my cursor disappearing upon resume, or LightDM locking me out after resume, which forced me to reboot my computer on several occasions. I’m sorry if my feedback seems harsh, but I wasted precious hours on Ubuntu MATE that I’m never going to get back.
I ended up spending several more hours trying to find a replacement for Ubuntu MATE, but I found that everything is pretty peachy on Linux Mint right now. I know that not everyone will encounter these issues, but I’m afraid I can no longer recommend Ubuntu MATE or any member of the Ubuntu family. From now on, my only recommendation will be Linux Mint 17.3. I hope this feedback is appreciated and is used to shape the future of Ubuntu MATE, so that others will not end up wasting their hours.

2 Likes

I have to admit to experiencing several similar and extra issues with UM 16.04. Which is why I have dropped back to UM 14.04 for the time being. Having said that, I have found that 14.04 is now showing some of the same issues (samba playing up and the AMD proprietry driver no longer working being two examples of bugs/breakages in 16.04 being somehow “ported” back to 14.04). These were not issues in 14.04 prior to the issuance of 16.04. Nevertheless, overall 14.04 is a lot more stable,. for me at least. Hopefully these issues will be resolved in 16.04 over time. It just seems to me that calling 16.04 an “LTS” release, implying that this is somehow “stable”, is misleading. It feels much more like an alpha release to me.

Oh, and lest I forget, my wireless connection in 14.04 is now broken as well. Or, that is to say, I get connection, but it drops out every few seconds. Luckily, I don’t have to rely on it as i have ethernet cabling set up. Again, this was not broken in 14.04 prior to the release of 16.04. So, I guess something has been “ported” back to 14.04 in this as well. As it happens, I also use the RTL card.

I do understand that most if not all of the above issues are likely to stem from Ubuntu as opposed to Mate. but it doesn’t provide much comfort to know that

1 Like

I wish I hadn’t had so many problems myself. Sound going away, no grub boot screen. Warning every time I opened steam. Minimizing Firefox and the desktop acting as if it was still there. I am using Antergos again. I have almost no problems. Ever.

1 Like

Yes, most of the issues do stem from the Ubuntu base. I feel that Canonical has kind of taken their eyes off of the ball when it comes to the desktop, which is kind of unfair for the amount of effort that Martin Wimpress and his team puts into producing this distro.
I would recommend trying Linux Mint (try both 17.1 and 17.3, they have different kernels) , or making sure that you download Ubuntu 14.04.0, not 14.04.4 which includes a newer kernel and might be the source of your problems. Don’t install the LTS hardware enablement stack.
You might try this guide to see if it fixes your Wi-Fi problems.

Linux Mint 17.3 is based off Ubuntu 12.04 – quite old.

That’s not quite right. Linux Mint 17.3 is based off of Ubuntu 14.04. Some of the software is more up to date than the versions included in Ubuntu 14.04. Furthermore, it comes with Linux kernel 3.19 which works really well with my Realtek card.

Oops. Wrong version. You are correct though. Mint is based on Ubuntu 14.04. Will Mint get these bugs when they upgrade their Ubuntu Base? The bugs are outside of Ubuntu actually. They are, in some cases, caused by conflicts within several OSS communities.:fearful:

While I don’t want to say in the slightest that the troubles anyone have don’t exist, I just wanted to add to the experiences:

Synapse: I had trouble in a previous version. I don’t remember if it was xubuntu or Ubuntu MATE 14.04 or 14.10 or… sorry, been too long. But after an update, it started working again (YAY) and has been stable for me with no problems.

Update manager: No problems here. Closest for me is that the Ubuntu Software Center runs glacially slow even on this mid-range not-too-bad desktop.

Panel layout: Only related problem I’ve ever had is that I saved my custom panel layout so I could switch things up and see what the options looked like - and when I went to restore my saved layout, it didn’t restore at all well. But I re-did my customizations and have been perfectly fine.

Wireless networking has worked without any problems for me at all.

So again, while I’m not arguing and saying you aren’t having these problems, I can say that Ubuntu MATE has been very good to me.

I’m sorry for your troubles. :frowning:

1 Like

I am sorry for your troubles …

I have been using Fedora and Opensuse for quite a long time (everyday needs) and i am back to DEbian/Ubuntu based distributions, using several Ubuntu’flavors without experienced those big troubles.

As far as i remember, synapse was crashing at the very early 16.04 released, but until now it seems ok here on 3 computers (was easy to fix the problem but sorry ,cannot remember how, “google i” if you like)

Never had so arround, exept if a API key cannot be load, for instance i ha this with Spideroak One

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com sudo apt-get update 2>&1 | grep -o '[0-9A-Z]\{16\}$' | xargs
that a way to fix it, but it doesn’t seems to be what you have encounter and what you expecting .

No problem here, but yes with compiz enable strange things sometimes appear, but no big dill. It completely fine with others windows manager such as marco and marco/compton

That is a point ! Wifi goes out on laptop Lenovo Edge E330 when come back from suspend (lid close)
have to restart in command line… but that one maybe will go back Gnome :yum:

Strange … Joe Collins was so enthusiastic with the Beta version( really appreciate what his doing through his web site and youtube channel) and has he wrote, things gone after …

Why was I so upset? Simply this: ALL of this had WORKED flawlessly
when the machine was running Ubuntu MATE 16.04 Beta and now it didn’t
work at all! I tested it weeks before I even thought of buying the Dell
laptop to replace the HP. The idea of shifting the HP to desktop status
had been knocking around in my head for a while.
“So, what am I gonna do now?” I thought to myself.
Answer: “I’m gonna install Linux Mint 17.3!” Guess what, folks? It
worked perfectly, yet again, and I’m writing this text on it right now.
[http://freedompenguin.com/articles/opinion/linux-mint-saves-day/](http://1. Wireless networking is completely and utterly broken)
And yes linuxmint has a good way to go for stable (goes out when it’s ready) … let’s see if those problems appear with the 18 beta version who released yesterday, cause this is based on Ubuntu 16.04 and the 17.3, on 14.04 (14.04.4 ?, not sure)
http://freedompenguin.com/articles/opinion/linux-mint-saves-day/

I hope Linux Mint 18 doesn’t inherit these bugs. Because Linux Mint doesn’t follow arbitrary release deadlines, they often have more time to ensure stability. If it does have these bugs, I might cling to Linux Mint 17.3 until the end of the support cycle (2019).

Yes, I used Compiz with Ubuntu MATE, but that was to remedy another problem. Even with Marco + Compton, the VSync is completely broken, and I would see tearing scrolling down a webpage or watching a Youtube video. That’s just embarrassing for a distro in 2016. I use Compiz not for the fancy effects, but because it makes my computer feel like it has modern graphics hardware (which it does). In terms of compositing quality, Compiz comes closest to Wayland/Mir out of every other window manager I’ve tried (Mutter is very close to Compiz quality).

Think your window manager is up to the test? Perform these three tasks. All of them should have smooth graphics. No artifacts as an object is moving, no horizontal lines should appear on the screen, all graphical elements should remain intact while they are moving.

  1. Drag a window slowly across the screen
    2)Watch this video, fullscreen and in the Firefox window.
  2. Scroll backwards and forwards (try different speeds, too) on a long, text-heavy webpage in Firefox like this one.

Keep note that these are not arbitrary benchmarks, these are representative of real life tasks. Windows, Mac OS X have been able to pass these tasks for years. Until Wayland becomes useful to me, I will be using Compiz.

I have not experienced any of these difficulties on my Dell Laptop.

*Wireless works perfectly [99% of my online activity is WIFI]
*Manually update and plan to do so until first point release
*Using the tweak tool has proven superior for me
*Top panel is hidden to provide more visible screen
*Bottom panel completely removed and replaced by Plank

Ubuntu MATE is my choice!

Linux Mint uses an older kernel (3.19). What would happen if you installed that kernel in MATE?

Could you please tell me your hardware specs? Because I would like to know what graphics card you use? What CPU? etc.

You could dual boot MATE with Mint, so you can have a working daily driver and MATE to test and post bug reports when needed. If the developers do not get report they can’t solve the issue.

You could try again after July 21st, that is the scheduled release of 16.04.1. It should solve a lot of issues. Then do not install it as the sole OS on your system, but on another partition.

I think it a bit harsh to say that it is the fault of Canonical, the maintainers of Synapse, Network-manager and so on do not work for Canonical, they work for other projects.

We do try and report bugs to the different projects, but we do not have every version of hardware there is so we need your input.

1 Like

It’s funny how it goes sometimes - there seems to be lots of bugs in Ubuntu 16.04… none of them affect me :wink:

I’ve used Ubuntu Mate 16.04 since beta on my main Laptop - apart from the occasional crash of the document viewer, nothing affects my workflow. I’ve sorted every minor problem with a bit of googling (eg. no wifi after resume… easy fix found - brightness at max after resume… easy fix found - gvfs/gvfsd-smb-browse high CPU usage… easy fix found ). Although TBF many “problems” are just down to my hardware, not down to Ubuntu.

Anyway, all OK here… oh, and Ubuntu Mate and Linux Mint are the only two distros that work for me… and I’ve tried them all over the years

Chris

1 Like

I haven’t encountered any of these bugs on the systems I’ve run Ubuntu Mate 16.04 on (not even the wireless problems - it worked fine with a RaLink-based USB WiFi adapter), though especially on the latter I’ve seen a lot of reports so far.

Screen tearing for me was fixed by using either Compton or an option in nvidia-settings, but that’s of course GPU/driver-specific.

Personally the most annoying issue I came across so far is that Caja gets utterly confused by media which can be both read/write and read-only (like SD cards which have that little lock slider).
If you mount an SD card for the first time in read-only mode, Caja thinks it will remain that way forever (on a per-user basis) and next time I mount it with the lock slider in read/write position, Caja complains that the device is read-only when I e.g. want to copy something onto there.

The bug report is here, if anyone wants to add something to it.

1 Like

For composition I prefer to use compton, it is light and by default works out of the box without tearing and no fancy effects. Yeah, I like Compiz but indeed it is not the best choice and I saw some bugginess but nothing too drastic.

The Wifi issues are real, after first install and after resume, I blame network manager as I saw the same happening on Arch. I also saw the occasional brightness issues after resume but other than that everything else is mostly great.

I really cannot complain about Ubuntu Mate 16.04. I had more problems with the main Unity version.

I would go with some of wizd3m’s suggestions, especially determining the hardware specs and graphics card.

I don’t know what would happen. I don’t suspect it would fix my Wi-Fi problems because I suspect that NetworkManager has a role to play in my problems too.[quote=“wizd3m, post:13, topic:6712”]
think it a bit harsh to say that it is the fault of Canonical, the maintainers of Synapse, Network-manager and so on do not work for Canonical, they work for other projects.
[/quote]

If you read my post, Synapse was segfaulting because of IBus. I managed to fix it by changing some configuration. I have not had this problem on other distros. It is Canonical’s fault for shipping a broken version of NetworkManager.

Sure, I’ve truncated the output from sysinfo to include the information that I think is relevant:

Oh, and just to be clear I have the problems with Compton in Linux Mint as well. Only Compiz, Kwin, or Mutter-based window managers get VSync right.

@ChrisK I’d be interested in the details of thos fixes you’ve found to see if upstream can be patched :slight_smile:

1 Like

Hi @Wimpy
Quick question:
It seems to me that a lot of driver related problems (especially network drivers) are often easily solved by dropping a one-line file in /etc/modprobe.d/${driver}.conf.
Is there a technical reason why those common solutions aren’t deployed by default in a new installation?

Cheers

I’ve got Ubuntu-MATE on three systems. An Dell Dimension 9150 desktop, a Dell Studio 1745 laptop, and a Acer Aspire One D-150 Netbook. And on all three of them, the only problem is the Network one. Can’t tell it on the first one, because it’s Ethernet only, no Wireless card, so it doesn’t count. :wink: The Dell laptop uses an Intel WiFi card, Intel WiFi Link 5100 using the iwlwifi driver, while the acer uses an Qualcomm Atheros AR242x / AR542x Wireless Network Adapter with the ath5k driver.

Now if I put UM 15.10 on both laptop & netbook, they both work fine, put 16.04 of any Ubuntu based Distro (Ubuntu,Xubuntu, Lubuntu, Kubuntu, Linux Lite 3.0 and our Ubuntu-MATE) on either one, and the WiFi breaks. :frowning:

I’m just hoping the next 16.04 point release has the fix included! Or if it’s a bug in the current Kernel, a patched one available for download.