Unfortunately, I no longer use Ubuntu MATE

Thats really interesting as my Dell Studio 1749 uses a different card and has perfect wifi and ethernet connectivity

Network:   Card-1: Broadcom BCM43224 802.11a/b/g/n driver: wl
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169

Yep, that is weird. Usually I have no problems with Intel stuff. The Intel video works like a champ though.

At least I had fun with a marathon of Distro installs. :wink: Since Ethernet works on all, I just keep the Laptop plugged into an extra Ethernet jack for Internet use. :wink:

1 Like

I’ll PM you the “fixes”, Martin

EDIT: I can’t find a way to PM on this forum, but I’m not awake yet… I’ll just paste it here:

The “fixes” are perhaps better described as workarounds, but I was trying for a positive post to balance the negative ones :wink:

However… here’s the brightness and wifi/network fix:

Paste the following code into a script and place in /lib/systemd/system-sleep and do “sudo chmod a+x /lib/systemd/system-sleep/your-script” to make executable:

#!/bin/sh
case $1/$2 in
  pre/*)
    #echo "Going to $2..."
    exit 0
    ;;
  post/*)
    #echo "Waking up from $2..."
    # Place your post suspend (resume) commands here, or `exit 0` if no post suspend action required
    echo 35 > /sys/class/backlight/nv_backlight/brightness
    service network-manager restart
    ;;
esac

Obviously the brightness fix is machine/driver specific, so needs editing for each machine, or changed programatically

The high cpu is only a stop-gap until a fix is found:

just disable the execution

sudo chmod 744 /usr/lib/gvfs/gvfsd-smb-browse

Chris

Hi @foxinsocks,

not to pick holes in your statement above but isn't Linux Mint based on Ubuntu?. :confused:

One of the main problems causing errors in the system is that people don't follow a few basic guidelines when creating their boot media and during the installation which I am sure you are well aware of!, I will put them below for the benefit of any beginners looking at this thread:

1: Always burn disks at the slowest possible speed to avoid read/write errors to the disk which will eventually lead to post install problems.

2: Always pre-format the USB stick to FAT32 prior to creating a image on the stick (for the same reasons as stated at #1 above).

3: Always install updates during installation which ensures that the latest updates install with the system and requires only a few more updates upon full installation completion.

4: Use the Welcome App to help with any post install fixes.

Welcome > Software > Fixes

4 Likes

The point is, the current version of Linux Mint is based on 14.04. from what I understand. Secondly, many of the kinds of problems listed in this thread are underlying and system related and clearly not due to some particular error in download. That is not to say that errors cannot arise from the things you have just mentioned. But, they are not especially relevant, I would argue, to what has been discussed here.

2 Likes

If compton does vsync wrong you should try to run it manually with:

compton -b --backend glx

You can also try some other options.

For more info read:

or have a look into compton’s manpage.

I know it sounds like additional work but I just try to point out some solutions.

Hi Steve,

I mentioned the things I did because even long term users of Linux can still do things wrong, I know I do from time to time!.

Trying to help others reading the thread so they can avoid pitfalls was my principal goal and I didn’t intend to insult anyone’s intelligence or belittle their PC skill-set!. :thumbsup:

2 Likes

Okay, these are good tips, but I didn’t make any of these mistakes when installing. Thanks anyways for the suggestions!

1 Like

Thanks Dave! I will be sure to check this out. I’ll let you know if I can get better results from compton when I have the time.

EDIT: Your command appears to actually do the trick. Cool. Do you know if there’s any reason why this isn’t the default? There really ought to be a Compton Settings Manager, there are a lot of settings I didn’t know existed.

2 Likes

I could (and had) complain (at length) about MATE Dock not working, but that was only because I am using an older version of Compiz, which makes it act funny.

I’m still barred from making a new issue, commenting on issues or even apologizing to its author for making what he perceived as a troll response so I’m the only person in the whole wide world maybe with this particular issue and because I had an angry Linus moment, I am unable to contribute further information about my issue. That aside, my point is to try the system in a live session to make sure these issues are not arising because of changes that you have made.

(BTW, could somebody PM me robint99’s E-Mail so I can apologize to him?)

Well if you like arch but dont like all the hassle it brings why not try Manjaro?
Its quite rock solid for a arch based distro

No idea. On Debian I always use that command or you put it in compton.conf. Though I have to say that on Ubuntu Mate 16.04 I just use the default settings without any fiddling at least on my T400.
It always depends on your graphics card. Onboard Intel very often has screen tearing if you do not use OpenGL.

Great idea - maybe something for MATE Tweak?

Nah. It should have its own dedicated control centre similar to what you can install for Compiz.

I think Compiz was causing some of the issues I encountered also, but I have used compiz on Manjaro xfce without issue so I can’t accept saying the problem was with Compiz.

I’ve never had these problems with the wifi, it’s rock-solid on my old acer aspire one 725. As are the panels, it boots and it works, all the time, every time.

The other issues, maybe is because I live in a terminal and use find, grep, apt-get etc 100% of the time. Usually, because they are quicker than the GUI versions.

I’d wait until 16.04.1 LTS comes out

1 Like

I didn’t say I liked Arch.

Just for reference, here’s an article that I think should be required reading for anyone who recommends Arch Linux: http://www.catchlinux.com/arch-linux-myth/

Here’s something that I believe everyone should read before recommending Manjaro: http://keithcu.com/wordpress/?p=3389
Highlight:

I don’t understand why so many small groups of people think they should
make an OS. At Microsoft, a team of 4 developers would be maintaining a
codec.

How can Manjaro go through thousands of packages and check/patch for stability and security problems? They can’t, and they end up keeping you from getting packages when they are ready (which poses security problems).
You don’t know all of the nice things that Ubuntu/Mint put into making their distros nice until you decide to try and replicate them yourself with Arch Linux (fonts, packages pre-configured with sane defaults).

I personally think it’s ridiculous that any user in the 21st century should think that they should spend their time going through and applying all of these little changes to get a good desktop experience, or that they should suffer through a bad desktop experience when Ubuntu and Mint distros come with a good experience out of the box.

TL;DR: Way too many people use Arch because it’s the cool thing to do; and I was one of them. If you’re happy with Ubuntu MATE or some other distro right now, don’t be tempted by Arch’s siren song. The grass isn’t greener on the other side and you’ll find yourself dashed upon the rocks of a poor desktop experience.

2 Likes

Actually the Manjaro team is very dedicated to its job and most of the issues of arch do not trickle down.

1 Like

I can’t speak from experience here about Manjaro fixing Arch’s problems in general but I know they haven’t fixed fonts.. The Ubuntu base is just really nice because a lot of the patches they have made lead to a better desktop experience.