Upgrade to 20.04

Hi everyone,

I have a question. Is it safe to upgrade to 20.04 from 19.10?

If so, what is the best/safest way to do it?

Thank you.

This brought me from 19.10 to 20.04, but in Virtualbox. On my main system I will uninstall GIMP first which I installed as PPA:

    sudo apt-get update && sudo apt-get dist-upgrade
1 Like

Thank you Newhere. I have Gimp installed as PPA as well and other programs. Do I have to uninstall them then before the dist-upgrade?

Hi @paulactea,

apt-get dist-upgrade is not upgrading from previous Ubuntu version. You may want to read release notes, where transition process is described. If you want to upgrade via terminal, do-release-upgrade command shall do the trick. External PPAs are usually disabled automatically during upgrade process, but you may disable them manually in advance.


Thank you ironfoot for your help, I want to upgrade from the terminal and I will do it that way.

When trying to upgrade, the only option was to the RC version. I think I'll wait for the official release.

if u update from 18.04 then do this update-manager -c -d and follow instructions

Now that 20.04 officially is out, I tried the method do-release-upgrade but got the following message on Terminal:

Checking for a new Ubuntu release
There is no development version of an LTS available.

However 20.04 LTS is available to download from https://ubuntu-mate.org/download/amd64/

I tried this method as well and got the message:

This release is still in development. Do not install it on production machines.

For some reason it seems it is not finding the official release

Hmm..which mirror u use?
When i use this command "update-manager -c -d" i don't have that message "There is no development version of an LTS available."
And btw i see post of ubuntu Budgie and they said "18.04 LTS users using the 64bit edition will be offered the upgrade to 20.04 in July/August 2020 when the first point release (20.04.1) is made available. "
So...will wait official answers from developers.

I put the command "update-manager -c -d" and then I get this:
Checking for a new Ubuntu release
Checking for a new Ubuntu release
/usr/lib/python3/dist-packages/DistUpgrade/DistUpgradeFetcher.py:23: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.

  • from gi.repository import Gtk, Gdk*
    /usr/lib/python3/dist-packages/DistUpgrade/ReleaseNotesViewerWebkit.py:33: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.
  • from gi.repository import WebKit2 as WebKit*
    Gtk-Message: 18:38:17.244: GtkDialog mapped without a transient parent. This is discouraged.

Then the Software Update window open, check available updates and finish with the message "The software in this computer is up to date. However, Ubuntu 20.04 is available (you have 18.04)."

I click on Upgrade and then I get the window with the message " This release is still in development. Do not install it on production machines.
I usually use the Australia mirror but this time I switched to the Main Ubuntu Server.

upgrade with update-manager -c subsribed here:

Doesn't work.

Well i look into there:

It's normal situation with this notification.

They update too through update-manager -c -d so that's normal message.

Yep, That's the same screen I get: Welcome to the Ubuntu 'Focal Fossa development release' etc. etc.

I don't know, I feel something is not right, perhaps I'm being too nit picky.

The option -d in Update-Manager means:

-d, --devel-release If using the latest supported release, upgrade to the
development release

-c, --check-dist-upgrades
Check if a new Ubuntu release is available

So when using Update-Manager -c -d It will find the latest development release, a.k.a. RC?, not the official release unless something is missing or I'm looking for the 5th leg of the cat lol. This didn't happen when I made release upgrades in the past.

OR the official release "is still in development"?


Well updated with update-manager -c -d all works fine

1 Like

Yeah, it could take a few hours (or even days) for all mirrors to sync across the world. :earth_africa: Changing the server in Software & Updates to point to Main server :gb: and refresh your sources might accelerate things.

At this time, it's okay to use the -d flag since 20.04 was just released and this just bypasses the check to stop users upgrading to what would normally be a development branch.

If I remember, users on 18.04 won't see an invitation to upgrade to 20.04 until the first point release is out (20.04.1) in a few months. It could be a few days for 19.10 users to see a notification (or do-release-upgrade without the -d ), in case there is a serious issue.

1 Like

Thank you volnes, I'm also getting the same upgrade message to the development release not the LTS. I think I'll wait until the LTS release is available, hopefully soon.

I'm just preparing the upgrade on my desktop system and I uninstalled GIMP. Was a bit of a hurdle, because Otto Kesselgulasch had changed something in the name last year. I had already difficulties to get the older 2.10.8 updated last year, and had to uninstall it and then reinstall. Today, first it couldn't recognize the purge. I then went to Software and Updates and went through 2 or 3 stages of setting a check for both Gimp PPA. At some point, I got GIMP uninstalled.
sudo apt-get install ppa-purge
sudo ppa-purge ppa:otto-kesselgulasch/gimp

I think it's important to remove Gimp PPA first, because once 20.04 is installed, I will then use the Software Boutique version. Back then in 2018, I wanted to use the new Gimp 2.10 which was just released one day after 18.04.

1 Like

Hi lah7, thank you for the suggestion. I changed the server to Main, refreshed, and still only get the option to upgrade to the development release.

Thank you for pointing that out Newhere, I will remove Gimp before upgrading so I won't run into any issues and use the Boutique one too instead.

Thank you for sharing the commands :slightly_smiling_face:

I’m currently upgrading. What I did was that I used my first part, the one I mentioned yesterday, to make sure I have all updates. This did the upgrade to the Beta 20.04 in my Virtualbox system. Then I opened Run Application using Alt+F2, and I entered
‘update-manager -cd’

I then was told that I was up to date but there is 20.04 available ... yes... upgrade.
I’m currently in stage Installing upgrades. Let’s see how it goes.

Maybe the Virtualbox works different because to my own surprise I found my test system suddenly in 20.04 Beta last month after using the update line (yesterday written).

[Update] It worked all fine so far.
With Gimp, I noticed that it is installed (2.10.18), but I can't remove it. Installing the PPA leads to some issues, obviously. But Gimp itself seems to work. I will install 20.04 from scratch on that desktop system (it's my test system and backup in case my main laptop has a problem).

1 Like