VLC displays black screen

If I watch a video (.mp4) in VLC using the default settings, I get a black screen - the sound plays, the progress bar advances, but no picture.

I can “fix” this in VLC’s video options by turning off “Accelerated Video Output” (overlay), but then the playback is choppy and the screen tears a lot particularly with 1280x720 videos, e.g. BBC get-iplayer files.

The laptop is a Dell E6410 with integrated intel GMA graphics, and I am running 64 bit Ubuntu Mate. I’m using Marco (Compton GPU Compositor) as my window manager, I have experimented with the various options there. I know the laptop is physically capable of this, it was OK under Linux Mint 17.2 previously.

Is there something else I should try?



Hi @quartz,

try installing the following package via the terminal (Ctrl + Alt + t) and see if that helps.

sudo apt-get install libxine2-all-plugins

Do you have the restricted Ubuntu codecs package installed?:

1 Like

This is not needed for VLC, as it does not use the xine library.

As the video does play if you disable acceleration this looks more like a driver- that a codec-issue.


Thanks wolfman.

Actually, the libxine2-all-plugins seems to have done the trick. VLC will now play with the Accelerated Video Output box ticked, and is free of jumping & tearing.

Thanks for your support :slight_smile:


1 Like

Could it be that installing that package also brought other common dependencies with it?
I’m a bit surprised the xine libs helped with this - I do not have them on my system yet VLC plays videos with acceleration enabled (GeForce 750 ti, Nvidia drivers).

It did pull in some dependencies but I didn’t take notice of what they were.

I only have on board graphics so maybe your graphics card makes things easier in your case.

1 Like

I have the same problem with mate 17.10. Using VLC or Kaffeine I get a blank screen but I do get audio. I have the restricted codecs installed and I added the xine libs and tried turning off hardware acceleration but still no video.



HI Ian,

what GPU do you have?, have you installed drivers for it?:

I have an Nvidia GPU and the drivers are installed. This problem only arose after the latest upgrade. Fortunately I have now solved it. It was a configuration problem with VLC.



1 Like

It’s just a setting within the video’s tab
Just within the Tools … Preferences … Click on Video … Under Window Decorations select from the DropDown box … select X11 !
Now video playback should work ! :wink: (y)

Tnx, installing libxine2-all-plugins for Mint 20.2 activated DVD video feed!

1 Like