VLC not playing commercial DVD's

After a lot of attempts to get VLC working on my recently installed Ubuntu MATE 16.04, VLC just will not play the commercial DVD’s. It did work one time and I restarted the computer but it would not work after that. My personal home DVD’s work. The computer recognizes the home DVD’s but not the commercial DVD’s.

I have installed the latest drivers using
sudo apt-get install libdvd-pkg
I check the Software Boutique and libdvdcss2 shows it is installed.
I have tried a couple of other options such as those found on the Ubuntu Ask Questions forums.

I have another computer running the same system and VLC plays commerical DVD’s after the recommended software libraries were installed. The computer that works with VLC commercial DVD’s is a Toshiba with 4GB of RAM and a 2.1GHz dual core processor. The current computer giving me problems is a Dell Inspiron-1720, 4GB or RAM and a 2.4GHz dual core processor. The Inspiron PC gave me some problems when I was running Ubuntu 14.04. It would play commercial DVD’s but cut out part way through the movie. I was running Debian Xfce for a while before installing Ubuntu MATE 16.04. Any help would be appreciated.

Hi @playinmyblues,

it might be a case of missing dependencies?, try the following terminal command (Ctrl + Alt + t) and do a restart then try playing a DVD:

sudo apt-get update && sudo apt-get dist-upgrade -f

Here are the error messages from VLC after running those commands from the command line:

File reading failed:
VLC could not read the file (Input/output error).
Your input can’t be opened:
VLC is unable to open the MRL ‘dvd:///dev/sr0’. Check the log for details.

The last two lines were what I was getting before. Here is the error message from trying to play the DVD with no menus (on the dialog box that comes up when you try to play a disc):

Your input can’t be opened:
VLC is unable to open the MRL ‘dvdsimple:///dev/sr0’. Check the log for details.

Perhaps try the following in terminal:

sudo dpkg-reconfigure libdvd-pkg

During my search for how to get VLC to work I had found instructions to run the following:
sudo apt-get install libdvd-pkg
sudo apt-get install ubuntu-restricted-extras

I ran them in that order, did a hard reset and now VLC plays the commercial DVD’s. I am not sure how the dependencies work as I previously installed those packages before but likely not in that order. I had also tried a number of other solutions that were probably outdated.

Now, if I could only get the Bluray player to work - located in the same drive. Remember, this PC was purchased in 2008.

AFAIK the correct sequence is:

(1) sudo apt install ubuntu-restricted-extras
(2) sudo apt install libdvdread4
(3) sudo apt install libdvd-pkg
(4) sudo dpkg-reconfigure libdvd-pkg

Reading commercial DVDs should now work.

1 Like

You can easily check the status of your hardware via the Device Manager. open the Start Menu and search for Device Manager.open the search menu. If there is a yellow exclamation mark next to Display Adapters, this could be your video playback problem. Double-clicking your adapter will bring up the properties menu where your device information will be displayed, along with any errors.

Selecting the Drivers tab will show you several options, including Update Driver. Clicking it will allow you to choose to either Search Automatically or Browse Your Computer. If you have already downloaded the driver directly from the manufacturer website, select the latter, browse to their location and install. If not, select Search Automatically and os will trawl your computer and the Internet to find the correct drivers for your hardware and then install them. For more information regarding video audio playback issue please refer to Dell Inspiron 1720 Manual- guideusermanual.com/product-name-inspiron-1720-manual&po=344168&lang=English

Ran those two commands and rebooted and it works now. Thanks for posting this fix.

Thanks Dave!! These commands got my VLC playing DVDs !!!

Much appreciated.