Weird software updates settings bug someone reported on IRC

<alyana> hi everyone is this a channel to ask a question?
<Akuli> yes
<alyana> oh good thanks, maybe someone could answer me that. I have
installed ubuntu-mate 16.04.1, and in the application where to
determine how often it should look for updates and security updates,
I did set to download and install security updates immediately. Now
after reopening that, this option is blank and not selectable anymore.
Is that a bug or intended or...?
<alyana> I can still set how often it should look for other updates, and
when to notify. But the drop down box in the middle, about the
security updates, is greyed out
<Akuli> i just remove the updater when i`'`m done installing ubuntu,
and i update with the terminal :)
<alyana> oh I see, when you update with the terminal, does that
include all the available updates then, no matter what type of update
it is (security, application, whatever...) ?
* kw21 ([email protected]) has joined #ubuntu-mate
<Akuli> yes, everything.
<Akuli> first i run sudo aptitude update to refresh my package lists, then
sudo aptitude upgrade to actually download and install the updates
<alyana> ok thank you. I will do that too then. I just wondered why I
could not change the settings anymore in that dropdown box. Any
other option in there is working well, also in the other tabs everything
looks ok. Just under "Updates" the option about the security updates is
blank and grey, and if something like that appears, I just want to know
<Akuli> that sounds indeed weird
<Akuli> then again, thats why i like the terminal :) it lets me control my
 system more directly
<alyana> yes, I am starting to use the terminal more and more often as
well... however disappearing options like that make me nervous :) I
could set it once. then I closed the application. Everything seems fine.
Reopening it, gives that behaviour. I have veryfied that on two different
machines now.
<alyana> and I did that directly after a fresh install
<alyana> maybe that application 'application & updates' itself needs an
update :) This has not happened on any other distro I have tried out

I reproduced:

Anyone know how to fix it?

1 Like

Its there in 16.04. But it appears to be already repaired in 16.10. It is not affected.

1 Like

I think I found the fix. There’s apparently a missing dependency with the package unattended-upgrades. Install this and it repairs the setting, at least it did in my VM.


Just tested on metal and indeed, box is repaired now.
@Wimpy, can you take a look at this?

Thanks a lot @Bill_MI.

@Wimpy may already have a hunch about a separate issue with this package not being present. I was never sure exactly why he suggested it in this thread for a different issue: Strange Mode Starts With Software Updater

Since the original reporter is now lost out there in the ether, do you want to file a bug report or should I do it?
(I’m asking since you kinda deserve the glory. xD)

Please go ahead. I’m elated enough my hunch worked. :grin:


1 Like

Already confirmed it. Both my 16.04 and 16.04.1 VMs do not have the dependency installed.

1 Like

I’m working on this now and will get it SRU’d to 16.04.


Fix was released to -updates just now.

1 Like

It looks like the 16.04/1.14.1 PPA meta packages ubuntu-mate-desktop and ubuntu-mate-core are in limbo. I’ve been trying to figure out how they create an install of unattended-upgrades (and pppoeconf, too) yet they, themselves, cannot be upgraded or they will break in synaptic. Yet they show up as an upgrade.

I checked and my standard 16.04/1.12.1 VM has no problem - the meta packages update fine. It has to be some kind of conflict. @Wimpy understand what’s going on?

Saw this issue reported on IRC earlier thank to @ouroumov. Should be fixed in the xenial-mate PPA now as well.

1 Like