When will Gimp be updated to 2.10


#10

It’s a bit weird: I’ve just tried adding the PPA to update GIMP and had no issues. No conflicts in APT, GIMP works fine, the Software Updater too…

Did you have outdated PPAs/3rd party repos? this might explain the issues with some packages.


#11

I had the same issues in Virtualbox when I had a clean UM 18.04 installation with Gimp 2.8.2. I will run another test in Virtualbox.


#12

Did you add the PPA and upgraded without first removing the gimp package?


#13

I did this:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp sudo apt-get update sudo apt-get install gimp


#14

Ok. I thought GIMP was installed on Ubuntu MATE from the beginning but I’ve just checked and it’s not the case. So, what you did should work.

I’ll try on my VM to check if there’s some weird packaging mistake in the PPA that would trigger issues.

EDIT: when I try to install it, it wants to install the following packages:
gimp gimp-data libamd2 libbabl-0.1-0 libblas3 libcamd2 libccolamd2 libcholmod3 libgegl-0.3-0 libgegl-0.4-0 libgfortran4 libgimp2.0 libjavascriptcoregtk-1.0-0 liblapack3 libmetis5 libmypaint libquadmath0 libumfpack5 libwebkitgtk-1.0-0 mypaint-brushes python-cairo python-gobject-2 python-gtk2

Same list on your side?

Then, it installs properly and starts without issues. So, not sure what is happening on your side.

If you run Softwares & Updates from the Control Center, you should have the following:

  • 1st tab: the four Ubuntu repos checked (main, universe, multiverse and restricted)
  • 2nd tab: the Partner repo (unchecked but it can be enabled) and the GIMP PPA
  • 3rd tab: the three update repos checked (security, updates and backports)
  • 6th tab: the Proposed repo unchecked (important)
    Do you have anything else or repositories that are not in the state I listed?

#15

Test 1:
I just installed UM 18.04 in Virtualbox and have the same error that I had before and in my main system. The entire system was broken and nothing could be fixed.
I then realised that I obviously hadn’t installed Synaptic Package Manager to use apt-get. Mea culpa. Sorry, I’m a Windows user and new to Linux.

Test 2:
I restored UM to original, installed Synaptic Package Manager from Software Boutique.
Installed Gimp 2.8.
Ran Otto Kesselgulasch’s installing instructions.
Result: Message tells me it can’t be installed because there is already the lastest version 2.8. installed
I then used the Flatpack instruction from the Gimp Download website
Installed flatpack
Installed Gimp
Result: Gimp 2.8. works fine, but I can’t find Gimp 2.10. Mea maxima culpa, I’m new to Linux.

Because I don’t need Gimp 2.8, now the final …

Test 3:
I restored UM18.04 to original.
Installed Synaptic Package Manager from Software Boutique.
Followed Otto Kesselgulasch’s installing instructions.
Searched for Gimp in Menu
Result: Gimp is listed and Gimp 2.10 openes fine :slight_smile:
I then updated the system with the latest update, and left ppa Kesselgulasch ticked in Settings.
Result: the system updates correctly and nothing is broken.

Summary for Beginners like me:
Don’t have Gimp 2.8. installed if you wish to use Gimp 2.10. Make sure you have Synaptic Package Manager
installed, and then follow https://launchpad.net/~otto-kesselgulasch/+archive/ubuntu/gimp and everything will work.


#16

Synaptic isn’t mandatory at all, it’s just a GUI to manage APT more easily. I’ll check your third hypothesis, as it implies that GIMP can’t update from 2.8 on a fresh UM 18.04 install while still installing fine when going straight from 2.10.

EDIT: nope, still no issues on my side. Are you using Ubuntu MATE in 32 or 64 bit?


#17

@terzag
As 64-bit. I’ve taken screenshots. Had to stop (work wise). Once I have installed Gimp, I will edit them and upload here the essential one.


#18

Just installed Gimp 2.10 which works so much better than 2.8. Thanks and Thumbs up to the GIMP team.

Here are the screenshots which however only happens if you install 2.10 on top of 2.8 (installed using Software Boutique).
Solution: have no 2.8 installed and install 2.10 using PPA instructions and all will work fine.

After installing on top of 2.8.:

When trying to launch Gimp from Menu - Graphics:

Crash report:

Content of Crash report:

Updating failed as the entire system update failed:


#19

For some reason, APT is unable to install the package it downloaded in a temp directory. Are you short on disk space or memory?

What happens if you do the following?

sudo apt-get install -f

Also, can you give me the output of the following command?

apt-cache policy gimp libgimp2.0

#20

@terzag
I have installed on my main system that’s important. I had the same error in my first main system, and that’s why I don’t care any longer what went why wrong before. I have Gimp 2.10, which works so much better. I’m happy.

Edit: I don’t have that Virtualbox version, I removed both failures. What I also thought is if you had installed Gimp 2.8 through Software Boutique.


#21

What I also thought is if you had installed Gimp 2.8 through Software Boutique.

In my case, GIMP 2.8 was installed long ago (on UM 17.04 I think) through the Ubuntu repos (Boutique, Synaptic, APT, whatever). I used Otto Kesselgulasch PPA a few days ago to update GIMP from my 2.8 version.

The tests I made in my latest messages were on a fresh UM 18.04 installed in Virtualbox.

There’s something I didn’t notice in your crash report: it’s mentioning overwrites of a plugin from gimp-plugin-registry. Did you try to install gimp-plugin-registry and/or other packages (I see G’MIC in your available updates) along GIMP 2.8 before using the PPA or during your tests in a VM? Is so, that might be the cause of the issue.


#22

Sorry, I am a novice and haven’t done anything, but only tried to install. I nade exactly the steps as described.


#23

Just to check this, can you give me the output of the following command (now that you have GIMP 2.10 installed)?

apt-cache policy gimp-gmic gmic gimp-plugin-registry

G’MIC is a collection of various filters while GIMP Plugin Registry is a collection of plugins. It’s possible that they’re packaged differently in the Ubuntu repos and in Otto Kesselgulasch’s PPA, which could explain why the update crashed. And you seem to have installed them (G’MIC is listed in the Software Updater capture while gimp-plugin-regisrty is mentioned in the crash report) but they’re not supposed to be automatically installed with GIMP.


#24

Here you go: It looks like I don't have them. I still wonder what was different in your case. We need another person to run a test.


#25

I can confirm that you don’t have them installed.

I’ll have to reinstall Ubuntu MATE on my laptop, I’ll do a quick test with GIMP.

EDIT: ok, I could replicate the issue. On a fresh UM 18.04, I had the idea of installing GIMP from the Software Boutique (which I never do, I’m so used to the command line that I manage my softwares directly with APT), as I realized you probably used it in the first place. And there’s something weird in the installation of GIMP from the Boutique. For some reason, it also installs:

  • gimp-gmic
  • gimp-plugin-registry
  • gimp-gap & mplayer
    And as it seems that the GIMP package from Otto Kesselgulasch’s PPA include files that are in the gimp-plugin-registry, the process breaks. I’m not sure if it’s a decision from him or if GIMP 2.10 added some new plugins that were independant before.

And the fact that it worked when you followed some of my instructions using command line is because they simply installed GIMP, no extra packages.

I’ll report the issue to him but it might be worth looking why GIMP from the Boutique installs extra packages. It’s likely a choice by the UM MATE developers (as softwares in the Boutique are more or less manually curated).

EDIT: so, until this is sorted out, if you want to install GIMP on UM 18.04, you have these possibilities:

  1. Stick with GIMP 2.8 if you install it from the Software Boutique.
  2. Install it manually rather than using the Boutique if you want to use GIMP 2.10, either through Synaptic or APT, by installing only the gimp package. In that case, it doesn’t matter if you install GIMP first then upgrade, or if you add the PPA first (but in any case, don’t install it from the Boutique while using the PPA).
  3. If you want to install it through the Boutique but still upgrade to 2.10, be sure to purge the gimp-plugin-registry package before adding the PPA.

GIMP 2.10.0 on UM 18.04
#26

Hallo Newhere

Screenshots - have you tried “Shutter”? It’s “Edit” function covers most basic editing needs. Unfortunately, the edit function’s dependencies are not yet included in the 18.04 repositories so you have to go and add them yourself:

Have fun. :slight_smile:


#27

Thanks, alpinejohn.

This topic was solved by reinstalling Ubuntu Mate and then installing Gimp 2.10 as ppa. My Ubuntu Mate and Gimp work marvellous.

OMG Ubuntu also mentioned issues and advised to remove Gimp 2.8 first if one wants t install version 2.10.


#28

Umm… I just installed 2.10 from the Software Center, and it worked just fine with 2.8 also installed. I’ve also installed it via flatpak, and it worked that way too.


#29

You can just browse ubuntu-software(can be installed from software boutique) for gimp and you will find a snap there(v2.10). Tried just now.