Youtube on 20.04.1 LTS is not playing on RPi4

Greetings all, I spent the better part of the weekend trudging through the internet looking for others with this issue. Granted, I'm still novice with Linux, I feel there must be a solution out there I'm missing.

Ubuntu MATE 20.04.1 LTS
Raspberry PI 4 8GB
128 GB Samsung U3 Micro SD
2 displays connected @ 1600x900
USB Keyboard/Mouse
CPU and GPU overclocked (but this was happening with the standard config as well)
Base image: ubuntu-mate-20.04.1-beta2-desktop-arm64+raspi.img.xz

On both a fresh deployment of Ubuntu Server + Desktopify as well as the main download for Raspberry Pi 64-bit, I've been unable to get Youtube to play a video in Firefox or Chromium.

I've been able to get VLC and other offline apps to work however. I've tried multiple browsers and I've looked for Codec packs.

Dropping in the stock Raspberry Pi OS (Buster) the site is working under Chromium.

I did find this, but it doesn't look like I can really do anything with it.

I'm using the 64bit RPi Ubuntu Mate 20.01.1 download pointed to under 'Downloads', and have u-tube videos playing regularly under FireFox and Chromium with no problems (so far) on Rpi4 4GB systems.

Thanks for the reply. However, I am not using a YouTube downloader, but I can look into it.

Neither am I - look at what I said, which is referring to the downloads heading at the top of the page

Hey! Look at my previous post maybe you have the same issue:

In a nutshell I had the same problem and it turned out to be an issue with the selected audio output device, which might be an issue in itself. Strange isn't it??? Anyway at least that solved the problem I had with Youtube.

1 Like

Awesome that must be it. I'm not using a sound device either. I will try it out asap.

Hmm.. i think i have the same issue here.. I was using a screen with HDMI input, then i purchase 2 screen at 120 $ each (DVI input only) and connect them to the RPI using HDMI to DVI cable.... and notice Youtube not working at all !

Was thinking it was VideoDecode, but it'S active on Chrome and Firefox..

So i did a re-direction with the RPI Tools to the audio jack.. not workinig either...

So something tell me i will need to add an argument on the config.txt to force audio to the audio input.. or connect a Bluetooth speaker ?

I'm using ArgonOn case with SSD .. RPI4-8G, Ubuuntu Mate 64bit 20.04 and now i figure out how connect my Bluetooth keyboard (using command line to be able to see the PIN # appear).. I have a Logiteck K850.. so it'S now attached to my Desktop computer, Work laptop and the RPI !

Any clue wich line argument i need to add into Config.txt to force Speaker out..
BTW.. i'm doing that for fun.. i don't have any speaker connect to it at all !!! And don't intent to watch Youtube on the RPI.. just spending time testing and learning for fun... !