Encrypted DVDs Do Not Autoplay

I have installed Ubuntu Mate 15.04.

When I insert an audio CD or a non-commercial DVD into the drive a window will appear asking me what I want to do. I know how to change the settings to cause the disk to automatically play with a particular program (e.g. VLC).

However, when I insert a encrypted DVD into the drive this window does not appear.

I am, however, able to open VLC and play the encrypted DVD without any problems so I am sure that all the software needed to actually play the DVD is installed.

There is a message in /var/log/syslog stating “Read of scrambled sector without authentication”.

This is an issue with the encryption. In some countries it is not allowed to distribute this. But it is easily solved. The easiest way is to use mate-terminal.

If you want all restricted codecs just install ubuntu-restricted-extras

sudo apt-get install ubuntu-restricted-extras

If you just want to play the encrypted DVD’s just install libdvdread4, but then you have to issue a following command, so the do the following (also in a terminal)

sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

Hope it helps


I have already successfully run the install-css.sh script.

When I start install to install ubuntu-restricted-extras Synaptic informs me that libavcodec56 will be removed. Would this cause any problems?


I do not now exactly what it does, but it doesn’t give me any problems. It seems it is replaced by libavcodec-extra-56.

The packages ubuntu-restricted-extras and libdvdcss2 are now both installed.

However, the message “Add. Sense: Read of scrambled sector without authentication” still appears in /var/log/syslog whenever I insert the DVD into the drive and no dialog box appears asking the user what should be done with the DVD.

Out of curiousity I installed Ubuntu Mate 14.04 along side Ubuntu Mate 15.04 on the same computer referred to in my original post.

Under 14.04 encrypted DVDs are recognized upon insertion, but not under 15.04.

It seems that distributions using upstart might recognize these DVDs upon insertion more often than distributions using systemd, but I am not certain of that.

This is all useful information. I’ll look into this and restore this functionality. I did trim down the codecs in 15.04 to more closely reflect stock Ubuntu, I’ll see what can be done for 15.10.

1 Like

Install “libdvdcss2” from here (32 bit):


or here (64 bit):


Install using Gdebi. :smiley:


Even with libdvdcss2 installed, encrypted DVDs are not automatically
detected upon insertion like non-encrypted DVDs are.

Thank you,


Hi Daniel,

maybe try upgrading to 15.10?:

This should be fixed in 15.10. Can you confirm it is fixed? libdvdcss can be automatically installed via Welcome.


The issue as described in my original post from May 13, 2015 (
Encrypted DVDs Do Not Autoplay) has
not been fixed in UbuntuMate 15.10 as far as I can tell. The issue remains
even with libdvdcss installed. Please note that I do not regard this as a
critical issue, but it would be interesting to learn its underlying cause
(e.g. issue related to udisks2, etc.).


1 Like

Try installing the former package “udisks” from Ubuntu 15.04:


Installing udisks made no difference.

Try running the following terminal commands:

sudo apt-get --fix-missing install

The above command downloads and installs any missing packages on your system.

sudo apt-get --fix-broken install

The above command downloads and installs any broken dependencies on your system.

Running the two apt-get commands made no difference.

Hi Daniel,

have you checked "Dconf Editor"?.

Dconf Editor > org > mate > desktop > media-handling:


I looked at my media-handling settings in dconf editor, and the are the
same as those shown in your screenshot.

When I insert a non-encrypted DVD and then run mount from a terminal the
last line displayed is “/dev/sr0 on /media/daniel Check Please type udf

When I do the same with an encrypted DVD, that line is not displayed.

Please note that this issue was not present in 14.04.