Good Disk Cloning Program for Linux


#1

What is a good easy to use Disk Cloning program for Linux, preferably a GUI interface.
I tried Clonezilla but it was too confusing and I did not want to risk doing the wrong thing and wiping out the drive I want to clone.

Thanks


#2

Gparted is a nice GUI program, It allows for resizing, moving, copying, formatting and deleting partitions within a drive or between drives.

However, if you are wishing to copy your OS main partition, you would need to log in with a live ISO and use Gparted from there on the partition in question. In other words, you can’t apply operations with Gparted on the OS partition you are currently logged in on. Though, of course, you can apply operations on another partition on the same drive (or any other drive) whilst you are ordinarily logged in.


#3

You might want to look at this - https://en.wikipedia.org/wiki/Disk_cloning and this - https://www.tecmint.com/linux-centos-ubuntu-disk-cloning-backup-using-clonezilla/ - and perhaps even this - Installing Systemback. I used Clonezilla (from a Parted Magic USB) yesterday to clone the entire hard drive (500 Gb) of this old laptop onto a USB connected SSHD and it seems to work flawlessly. Good luck daldude.


#4

http://clonezilla.org/fine-print-live-doc.php?path=./clonezilla-live/doc/03_Disk_to_disk_clone/09-starting-cloning.doc#09-starting-cloning.doc shows the copying of the master boot record.

Both disks need to be unmounted. The destination disk needs to be same size or larger than origination disk. It is best that one uses clonezilla from a usb key to clone a hard drive in the computer to another hard drive, which can be either in the computer case or accessed as another usb drive.

For both beginners and expert users, Clonezilla sets the standard.


#5

I currently use both Clonezilla and ReDo. ReDo has a very simple GUI and works flawlessly for me on my older hardware. I went to Clonezilla for my new laptop as I could not boot ReDo on a secure boot system. Being forced to use Clonezilla, I have come to realize that it is not as difficult as it originally appears. However, I sill prefer ReDo and wish it was still supported.

BTW…With my Ubuntu-Mate 18.04LTS desktop build, it takes 6 minutes to back up my system and 3 minutes to restore using ReDo. The saved image is only 8.9GB.

Also: I could not find the link, but I remember an app named Veeam being discussed in this forum as well.


#6

How do you move partitions? All I could ever do is just resize them by moving either side of them by grabbing that bar and sliding it in or deleting the next or previous partition and expanding the partition. There is no cut or copy option and you can’t click on a partition and drag it to another unallocated partition, also you can only display one drive at a time so how could you copy a partition on one drive to another?


#7

right click on a partition and select “copy”. Then, go to an empty space on a drive (where the empty space is bigger than the partition you are copying) and right click and select “paste”.

I think…

I’ll need to re-check when I get home from work


#8

Also, see here:


#9

Cool, Thanks.
I don’t know why I did not figure that out before or maybe it did not work because the partition I tried to copy was mounted. Right now I’m testing it by copying some of my smaller partitions and my Windows 10 partition to a USB Drive to see what happens if I try to boot from it on another PC could not copy the Linux Partition since I’m running GPARTED from Linux on my PC and not a Live Jump Drive with Mint 18 on it.


#10

I have gotten in the habit (reminded by my Thunderbird calendar) of copying my critical partitions to an external device with Gparted.
Once you do it a few times it becomes just another mindless task.
15 minutes about once a week.

My key is keeping All partitions down to a manageable size… typically 15GB for / and maybe as big as 35GB for /home. (don’t forget to include the relevant swap partition!)
Other data on the other partitions is covered with normal backups… no need to copy those partitions.


#11

This did not work for what I want to do, I’m thinking of getting a SSD and don’t want to have to reinstall my Operating Systems so I want to clone the partitions on the Hard Drive to the SSD but my Hard Drive is 1 TB and I’d like to get a 512GB SSD because they are less expensive than a 1 TB SSD and would need a program that will make an exact copy on the new drive even if it’s smaller. My Operating Systems combined and the SWAP Partition take up 186 GB so 512 GB is more than enough and 1TB would be over kill and unnecessary so a 512 GB SSD is the most logical, piratical and cost effective way to go.


#12

You can’t copy a larger drive to a smaller drive.

You can copy a partition of size x from a large drive to a smaller drive so long as the smaller drive can still accommodate the partition of size x. But, you cannot copy an amount of space, be it a partition or an entire drive, onto an another drive or area of another drive that is smaller than it. That is physically impossible irrespective of the software you use.

On the other hand, are you saying that your OS and swap are using up 186gb and so have a lot of empty space on their respective partitions? If so, then all you need to do is resize your partitions smaller before attempting to copy them over to the smaller drive. Then, when the copying process is complete, you can resize the original partitions back up to their original size.


#13

When I upgraded to 18.04, I cloned my 16.04 installation from a 240GB drive to a 110GB drive with the help of this forum here.


#14

I personally use grsync. The progress bar is hosed, but it’s an incremental backup; new files only are backed upon subsequent backups. It uses all the switches rsync does, and is easy to use.


#15

So if your OS became unbootable, how would you restore your system using rsync?


#16

I do not back up /.

I back up /home. If / becomes hosed, I just reinstall, selecting the large drive as /home, and my SSD as /.

IF /home becomes hosed, I have a complete backup.


#17

None of these methods work for my situation because I want to clone a larger Hard Rive to a smaller SSD to transfer my 2 Operating Systems from the 1TB Hard Drive to a 480 to 512 MB SSD, it’s not worth the hassle of trying to get it to work or reinstalling the Operating Systems because I have everything set up the way I want and don’t want to have to reinstall all my Apps and Drivers. I’ll just wait until I have to update Linux MATE 18.04 in 2021 when support ends for it or if my Hard Drive goes bad until I upgrade to a SSD, I can live with the boot up time of my system since it’s not unbearable.

Thanks to everyone that replied and tried to help.


#18

I explained in my immediately previous post how you can do it. You need to resize your existing partitions down to a size that will fit on your SSD. Then when the copying process is done, you can resize your original partitions back up to their original size.

The only reason the above would not be possible would be if your original partitions, even if they are sized to to the minimum possible (due to existing data content) were still to big to fit the SSD. But, if that is the case, then I am bound to ask why you are asking for advice on how to achieve the physically impossible - irrespective of what software you use. It would be like asking how to fit two litres of milk into a 1 litre jug.

In which case, The only possible glimmer of hope might be to use something like Clonzilla which, I believe does compress data a bit. But, not by much, if I remember correctly

I am happy to show you how to resize a partition if you need to know. Just ask.


#19

In post #12 I provided a link where I successfully did exactly what you want to do, move a OS to a smaller drive.


#20

How do I clone this setup? I want to clone sda1 thru sda5 and the total is less than 149 GB you can’t use GPARTED to copy an un-formatted partition but that partition is need for Windows to boot plus it won’t let me create or copy more than 4 partitions because it says you can’t create more than 4 primary partitions and you can’t create an extended partition and then copy a partition from 1 drive to another because it will overwrite that partition on the target drive replacing it with what ever type of partition was on the source drive.
I tried copying sda1,sda2,sda4 and sda5 to another drive hooked to a USB part and then tried booting it from another computer and it either hung at a blinking cursor or gave me a no operating system found message from the computers BIOS.