How to disable Clock on the Indicator applet on MATE Panel?

I want to use the old clock applet in the MATE panel, instead of the clock in the indicator applet. Therefore, I don't want Ayatana indicator to display the time.

I disabled "Enable this Indicator on login" for the Date and Time entry in Ayatana Indicator settings, but it continues to show the time.

I am using Ubuntu MATE 22.04.

(Left: The old clock applet. Right: The clock in Ayatana Indicator applet, which I cannot disable)

After disabling the "enable this indicator on login" button, have you tried logging out and logging back in?

Failing that, open up Startup Applications (Brisk menu -> Preferences -> Startup Applications, or Classic System menu -> Preferences -> Startup Applications). That should open a dialog with a list of programs set up to start running every time you log in. Look in the list for an entry like Ayatana Date & Time Indicator, and if you find it, uncheck the checkbox to the left of the entry. Then log out and log back in again.

I hope that helps.


Tried, but that did not work.

That worked. Thanks!!

1 Like