I get logout of session everytime I go four times deep in any directory with terminal

Good day everyone.

I'm a big fan of Ubuntu mate. I finally installed the latest LTS version on my old 64-bit PC today but I found out that anytime I tried using the terminal to go four times in subdirectory I'm logged out of session and ask to login again with password. I meant cd dir-one/dir-two/dir-three/dir-four

I also experience same problem when I choose open in terminal once I'm four times deep in file management

I'm confused as I would mostly use the terminal for navigating my files.

What could go wrong?


Welcome @Precious to the community!

1 Like

I tested on um22.04

user@um3:~$ mkdir -p d1/d2/d3/d4
user@um3:~$ cd d1
user@um3:~/d1$ cd d2
user@um3:~/d1/d2$ cd d3
user@um3:~/d1/d2/d3$ cd d4

# system works
user@um3:~$ cd d1/d2/d3/d4

# system works

user@um3:~$ lsb_release -r
Release:	22.04

1 Like

Hi, @Precious :slight_smile:

Hmmm... Does your old 64-bit PC - that is running Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") - have an "Intel HD Graphics" as its "Graphics card" (also known as "Video card"), by any chance? If you don't know if that's the case or not, you can run "MATE System Monitor" (in the Ubuntu MATE Menu, search for MATE System Monitor or navigate, from the Ubuntu MATE Menu, to "System Tools -> "MATE System Monitor"). When the "MATE System Monitor" window opens, in the first (default) tab ("System"), check what appears in the "Hardware" section, and specifically in the "Graphics:" line of that Hardware section.

In case you find that your PC does have an "Intel HD Graphics" card: here in the Ubuntu MATE Community, in another older somewhat similar discussion, started in September 2022, by @Ygor6889 (Ygor Oliveira Silva) - "Ubuntu Mate 22.04 auto ending Sessions when I do something specific" - the user @esan_br (Elias Andrade), that has a "Dell Latitude E6410" which also has an "Intel HD Graphics" as its Graphics card, solved the issue that was also happening to him, in "Ubuntu MATE 22.04 LTS" ("Jammy Jellyfish") by:

1 - Creating a file "/etc/X11/xorg.conf.d/20-intel.conf"

2 - Putting the following content in that file:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"

3 - And then rebooting the computer.

Link to that post from @esan_br that he wrote on 1st October 2022:

In that same discussion, the user @Ygor6889 (Ygor Oliveira Silva), that started that topic and that also has a computer with an "Intel HD Graphics" video card, says that @esanbr's solution worked for him as well:

So, @Precious, if your old 64-bit PC does have an Intel HD Graphics card, then I suggest that you try @esan_br's solution, see if it works for you and then reply again in this same topic where we are now, to tell if that solution also worked for you (or not).

Good luck! :slight_smile:


My old PC have the following:

Graphics: Mesa Mobile Intel® GM45 Express Chipset (CTG)

Hi @ricmarques do you think that method would work for me? I don't know if my graphics is HD or not.

I just tried it out and it worked!!!!! I'm glad I can now use Ubuntu MATE😎. A big fan of it. Thank you @ricmarques


You're welcome, @Precious :slight_smile: I'm glad that @esan_br (Elias Andrade)'s solution also solved your auto-logout problem in your old 64-bit PC running Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") with a "Mesa Mobile Intel® GM45 Express Chipset (CTG)" (OpenGL) graphics (renderer). Thanks for reporting back as it can be really useful to other users. :slight_smile: By the way, could you run the following command in a Terminal window and paste the output to another reply in this same topic?

inxi -SG

... which is the same thing as running the following command:

inxi --system --graphics

In the case of this laptop - also running Ubuntu MATE 22.04.3 LTS ("Jammy Jellyfish") - that I'm using to type this message, the output is the following:

$ inxi -SG
  Host: riclaptop Kernel: 5.15.0-91-generic x86_64 bits: 64
    Desktop: MATE 1.26.0 Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nouveau
    v: kernel
  Display: x11 server: X.Org v: driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1440x810~120Hz
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2)
    v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1

Sure!! @ricmarques Here's my output:

  Host: multiverse Kernel: 6.5.0-14-generic x86_64 bits: 64
    Desktop: MATE 1.26.0 Distro: Ubuntu 22.04.3 LTS (Jammy Jellyfish)
  Device-1: Intel Mobile 4 Series Integrated Graphics driver: i915 v: kernel
  Device-2: Chicony Camera type: USB driver: uvcvideo
  Display: x11 server: X.Org v: driver: X: loaded: intel gpu: i915
    resolution: 1280x800~60Hz
  OpenGL: renderer: Mesa Mobile Intel GM45 Express (CTG)
    v: 2.1 Mesa 23.0.4-0ubuntu1~22.04.1