Installed Skype in 16.04, but won't launch

Installed Skype in 16.04, but it won’t launch. In terminal the command line yields this cryptic message "Aborted (core dumped)
" - Any suggestions?

Hi @jmarkus,

did you install from Skype's own website or via the Software Tools in Ubuntu Mate?.

Have you done a full system update?:

See also:

Hi Wolfman, I installed from MATE’s Software Boutique. I’ve run the software updater, as well as update/upgrade through the command line in the terminal. The Welcome center was taking so long to load at boot time I had un-ticked the open at startup thingy. So I have never seen the “subscribe to welcome updates” popup.

Hi @jmarkus,

so are you saying it still isn’t working as it isn’t clear to me?. :confused:

What graphics card and CPU do you have?. :smiley:

Yeah, still no go…except I get no error message at all now after doing the Welcome screen updates). (Use to say “unexpectedly crashed”, and/or “Aborted (core dumped)” via the terminal.

Graphics is a nvidia 6200 4x agp 128mb (Asus branded)
Processors are two AMD Athlon 2800+ MPs (Barton cores - 2.13 ghz each)
Motherboard is an Asus A7M266-D Revision 1.04 with the last beta bios - I think it is v1.011 beta 3 (mainly for the CPUs micro code)

Everything else I have used runs fine. In fact, Firefox has never been so stable before. In ubuntu 16.04, lubuntu 16.04, and feya v0.3.2 - I had constant Firefox crashes, and system lockups. However, I think it was all due to an old 4x agp era ATI graphics being a toxic mix with the K7 generation AMD CPUs. Since switching the graphics card it really runs sweet.

Oooops - it does generate the error message still - it just takes about 5 minutes to show up

Have you installed any drivers for your Nvidia graphics card?:

Control Centre > Hardware > Additional Drivers:

Also open Welcome (Top panel > System > Welcome) and then on "Software > Software Boutique > Fixes" (spanner/wrench symbol) and there are a few options open to you:

I have nvidia’s driver version 304.131 installed. Just wish the terminal pointed to something specific. For example: darktable won’t run either, but that is because the cpu lacks SSE3. I also have run the “fixes”.

I do wish the software boutique had a search function. Been using the synaptic package manager, and ubuntu software center when I can’t find something quickly. It also seems to hang on some installs, or takes a long time compared to the spm or usc,

Sounds to me like you have a broken install with so many problems?, how did you do your install?, disk or USB stick?:

I always verify my disks. Looks like I will have to just accept that skype will not work - thanks for the suggestions.

Hi @jmarkus,

don’t give up just yet, I have a suggestion albeit a bit drastic and it is to completely wipe your Linux partitions and re-install!, the reason I say that is because I did exactly that for myself and a friend recently as both of us were having problems with installs of Ubuntu Mate 16.04, since I did this, our PC’s run fine!. :smiley:


Hi wolfman, I’m not willing to wipe the install again. This is a dual boot box of old hardware (circa late 1990’s) I experimented with multiple distros trying to find the one that could run well on such old hardware. Ubuntu MATE is the best. I tried ubuntu, ubuntu studio, lubuntu (which I used for about a year), freya v0.3.2, l, debian 8, & Mint, I liked things about all of them, but the responsiveness of MATE 16.04 is noticeably quicker. I have many laptops and desktops running various distros. 16.04 is breaking a few applications. For example: avidemux. I’ll wait and revisit skype again in the future. Love how samba worked right out of the box, but we all know that some things take a little work. I’m a patient person. Thanks for the help - I really appreciate it.

1 Like

I suspect current Skype needs instructions that the AMD Barton doesn’t have. There is a lot of software that won’t run on the old Athlons because of missing instructions.

From AMD:
“Early K7 (Athlon) cores initially supported microcode updates as well, until ironically the microcode update mechanism itself was found to be broken and subsequently listed as an erratum.”

1 Like

" … 4x agp era ATI graphics being a toxic mix with the K7 generation AMD CPUs."

I’ve got a Barton system with an AMD/ATI Radeon R200 (Radeon 9200) GPU. It runs fine – no lockup. I add “acpi_enforce_resources=lax” to the kernel boot options in grub to keep the kernel happy about overlapping hardware.


1 Like

Hi @jmarkus,

okay; then try the following, remove Skype with the following terminal command (first make sure that you have Canonical repo ticked in "Software & Updates > Other Software > Canonical", change your software sources download location to something other than how it is set now!):

sudo apt-get remove skype && sudo apt-get update && sudo apt-get install skype

I hope it helps!. :smiley:

I suspect you are right Dave. Under the details of the unexpectedly crashed - in the “JournalErrors” section is this line “…Kernel microcode:AMD CPU family 0x6 not supported” [i just found this]

EDIT…I tried changing bios settings concerning ACPI, but it didn’t change the stability while using ATI graphics with this board. It is a weird board. Takes 4GB of memory, but if you put that much in…very few graphics cards will post. I’m not sure why that is. I found a post from 2006 on where a guy pulled a stick of ram and all his graphics problems were magically cured. So in desperation I tried it. Suddenly all the cards i had tried before and had failed to post - worked?
Maybe the bios can’t map that much memory. I added a 256mb of registered ECC to the fourth slot (the other three with 1 gb sticks) and it still works great.

wolfman, I tried the terminal command it changed nothing. If I understand SNAP right - can’t I just use an old version of skype since all it’s dependences are self contained and won’t fubar the system?

If you have an old .deb package, try installing it with Gdebi, you should get a warning that a newer version is available!. :smiley:

“Segmentation fault (core dumped)” with version v4.0.0.8-1_i386

Asus A7M266-D supports 3.5 GB registered memory. 4GB is unreliable. Supports 2 GB unbuffered ram.

With 4GB, there is no aperture memory hole for graphics. Newer chipsets/northbridges can map the
aperture over existing memory. The AMD 762 / Radeon combination cannot.

[    0.000000] AGP: Node 0: aperture [bus addr 0x00000000-0x01ffffff] (32MB)
[    0.000000] AGP: Your BIOS doesn't leave an aperture memory hole
[    0.000000] AGP: This costs you 64MB of RAM
[    0.000000] AGP: Mapping aperture over RAM [mem 0xb4000000-0xb7ffffff] (65536KB)