Installing Ubuntu mate

Hey, I'm having trouble installing Ubuntu mate. The installer works until I reach the final stage (the actual installation with the progress bar). I cannot progress past the configuring keyboard stage.. I get an error saying that the installer has crashed.

Btw.. the installer slideshow graphics show an outdated screenshot from bionic and vivid. (The screenshots of the info page show the version numbers). And for some reason I have 2 in my slideshow..

1 Like

Welcome @Zero to the community!


Thanks.. I've been meaning to sign up for a while..

1 Like

You've tagged 21.10?

Why are you trying to install Ubuntu MATE 21.10? It's EOL.


I'd check your release, the 21.10 tells you it was the 2021-October release, as Ubuntu releases use a year.month format (2000 is added to the year), and 21.10 wasn't a LTS release so installed systems upgraded to Ubuntu MATE 22.04 LTS before it reached EOL.

I'd suggest instead installing a supported release, and not worry about issues with an EOL release.


I was using a third party boot manager to download it.. I just tried using the latest image but same issue..

Are you downloading it from the official site?
What program are you using to extract and write it to your USB?
Are you verifying the checksum?
Have you tried a different USB drive?

Yes, I've downloaded from the official site.. I used Etcher to write and verify the image..

Hi, @Zero (Daniel Mcvittie) :slight_smile:

The official Ubuntu MATE Download web page - - has 2 download sections/boxes for the Raspberry Pi (one for 32-bit and the other for 64-bit) :

Raspberry Pi

32-bit. Compatible with models: B2, B3, B3+, B4 and 400
[ Link: ]

Raspberry Pi

64-bit. Compatible with models: B3, B3+, B4 and 400
[ Link: ]

If you click on either the 32-bit or the 64-bit download links for the Raspberry Pi above, you'll see that the only Ubuntu MATE version currently available in those web pages is the 22.04.1 LTS (Jammy Jellyfish). So, I'm a bit confused when you write that you have "(...) downloaded [21.10] from the official site (...)". What web page did you use to download 21.10? May I suggest that you download and use the 22.04.1 version instead?

You may also want to read the "Raspberry Pi Installation Guide | Ubuntu MATE" - - if you haven't already.

I hope this helps :slight_smile:

1 Like

Hey, I meant to say that after the failed installation, I downloaded a fresh copy of 22.04 but encountered the same issues