Internet connection stopped working after months

Some months ago I installed Ubuntu Mate 22.04 on my old(ish) Dell laptop. Internet worked fine - I was using both ethernet and wifi. Yesterday both ethernet and wifi stopped working. I rebooted the laptop, I rebooted the router. Nothing helped. Other computers connected to the network, have no problem with internet connectivity. I booted the problematic laptop into Windows (it's a dual boot, but I hardly ever use Windows) and the internet worked just fine. I booted the laptop into Ubuntu Mate 2022.04 from a USB and the internet works just fine (I'm actually writing this from there).

I am able to connect to my lan. It's just the internet that's not working.

So what's wrong? Where do I begin to fix this hugely frustrating problem?

Any and all help will be highly appreciated.

1 Like

Hello duvenhage

You could try deactivating IPv6:

It is one test that is easily done. :slightly_smiling_face:



If you are able to connect to lan but not to the internet, first try this:

ping -c4

if that works, try this:

ping -c4

If that doesn't work, it means that your DNS is not working.
either your computer doesn't receive DNS adresses from your router during DHCP
or your DNS-resolver stopped working.

If you open a terminal and type:

cat /etc/resolv.conf

it should show you something like this:

options edns0 trust-ad
search xx.xxxx

Also, this "file" should actually be a link. Check:

ls -l /etc/resolv.conf

which should show something like:

/etc/resolv.conf -> ../run/systemd/resolve/stub-resolv.conf

If you have that but it is still not working, further troubleshooting is needed :slight_smile:


Thank you, I appreciate the answer. I followed your advice, but unfortunately it did not work.

I wonder whether it could be driver related?

Anyway, I'll keep looking around. There must be a solution somewhere.


Thank you, I appreciate the answer. Unfortunately, as with alpinejohn's advice above, it did not solve the problem.

Gotta keep looking :stuck_out_tongue:


That your wired connection is not working is unusual. Yet the first thing I would try is booting into the old kernel that worked. Did this start happening after an upgrade?


Thank you for the suggestion. I only have two kernels available: 5.15.0-56 and 5.15.0-57. I booted into both and had no luck.

I'm pretty sure it happened after an upgrade, but cannot swear to that.

What really confuses me is that I can access my lan, transfer files to and from other machines on the lan, and these other machines are all connected to the internet without any problems. And all my machines run Ubuntu Mate 20.04 or 22.04.

Anyhoo, I'll probably end up reinstalling Ubuntu. Again. :frowning:

1 Like



Hello tkn

Is there a Haiku for firewalls? :face_with_head_bandage:


Well , i guess this is a dns problem.

  • ping , it should work, if not, your route configuration may be wrong.use ip route to check route configuration.
  • run host or dig or other way to resolve the hostname as you like, if it wroks , your network should be OK, then your can ignore the rest.
    If not, try to change your dns.
  • try resolve hostname with dig @ , dig @2001:4860:4860::8888, if they work well , add nameserver , nameserver 2001:4860:4860::8888 two lines to /etc/resolv.conf .(remember to comment your local dns)

good day.


And are you sure that your BIOS is up to date?

This happened to me after an upgrade. DNS was messed up. This installation was using Network Manager. What fixed it for me was entering the correct DNS entries for each interface managed by NM. I had been maintaining DNS in a single file somewhere under /etc, but the upgrade broke that somehow.