Minecraft Pi edition how to get survival?

Hey, everyone, I have messed around with Minecraft Pi edition on my RPI 3. Messing with Python and doing cool things. One thing that is a little sad is that there is no survival. What kind of game has no win or lose. I did research and it shows me how to do it, but most of them are meant for raspbian and I have Ubuntu Mate. Also, I tried to do one of them and it said to put a file into the mcpi folder. I don’t even have that folder anywhere. Probably because my Minecraft pi edition came preinstalled without that dir. So I made my own mcpi folder and I have Minecraft Pi on my panel so I just dragged it to the mcpi. Still no luck. The tutorial I was trying to do is at this link.

https://thebraithwaites.co.uk/minecraft-pi-edition-maps-texture-packs-survival-and-more/

It’s called the mcpi folder because if you were to download the original package linked by Mojang, it would be unpacked into a subfolder called mcpi.

On Raspbian and MATE, the built-in equivalent is /opt/minecraft-pi so just use that. The tutorial you linked is fine… just note the folder is owned by root so you’ll have to sudo some of those commands.

sudo apt-get install bspatch
cd /opt/minecraft-pi
sudo bspatch minecraft-pi survival ~/Downloads/survival.bsdiff
sudo chmod +x survival
./survival

For reference, the original thread by the guy who made the patch(es):

THANKS SOOOOOOOO MUCH AGAIN!!! YOU ARE THE BEST GUY TO MESSAGE FOR A MINECRAFT PROBLEM KEEP UP THE GREAT WORK!!! :laughing:

P:S The survival can I still do all the python stuff with it or only with creative?

1 Like

You can still use the Python API. In fact, it becomes rather essential if you want to kill anything. Useful link:

Thanks Again! :slight_smile:

I’m now getting this error saying.

./survival: error while loading shared libraries: libGLESv2.so: cannot open shared object file: No such file or directory

If you can fix this it would be greatly appreciated.

Have you installed the OpenGL|ES 2.0 library?

sudo apt install libgles2

Having the same issue running ./survival.

Get the same error running ./minecraft-pi so seems to be a problem running executables from the terminal.

@joetgmt1 and @commandery11

Is regular creative mode Minecraft Pi working, while survival mode is now hitting this error message?

If so, I recommend checking the wrapper script as it’s more robust against changes to the system libraries. If you take a look at /usr/bin/minecraft-pi I recall it says something like this on Ubuntu MATE:

cd /opt/minecraft-pi
LD_LIBRARY_PATH=lib/brcm ./minecraft-pi

You can run the same commands on your terminal, except change the last part to use ./survival

I went to run this and I got this error

[email protected]:/opt/minecraft-pi $ ./survival

  • failed to add service - already in use?

How do you fix this?

Hey @Sponge78989,

Users would get that error on Raspbian Stretch when switching to the full OpenGL driver. If you happen to have also changed the rendering driver on Ubuntu MATE too (less common), try reverting it back?

sudo raspi-config

It’s also possible with a wrapper script to get Mineract Pi running on the standard OpenGL ES driver on Ubuntu MATE, but the process is error-prone and wouldn’t achieve the same rendering performance anyhow.

I got chrome os how can i play Minecraft pi edition

Assuming it’s an ARM Chromebook, this is the basic procedure to tinker with Minecraft Pi on systems other than a Pi:

  1. wget https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz && tar xvf minecraft-pi-0.1.1.tar.gz
  2. git clone https://github.com/XECDesign/mcrpi-wrapper
  3. Follow README to build and run via LD_PRELOAD.
  4. Look through the first round of errors and start troubleshooting :slight_smile:

I wonder if there are any new commands featured in the survival mode and if not how I can create some?

No new slash /cmd style commands in MCPI survival.

As for building your own commands in Python, the RaspberryJuice plugin has a .pollChatPosts() function but unfortunately this isn't available in the original Pi Edition.

I guess in theory it's not too farfetched if someone were to build a tool to snoop the chat buffer and effectively implement .pollChatPosts() on the Pi.

Since I couldn't run survival mode with ./survival I fooled the raspberry pi to think it was opening minecraft but it's instead opening survival for me.

Here's the code:

cd /opt/minecraft-pi
mv minecraft-pi mcpi
mv survival minecraft-pi
minecraft-pi

Here's a better tutorial
Download the Survival Mod, setup files, laucher through

Hey jdonald i was looking for a way to change minecraft-pi to survival and came to this post! Everthing worked fine expect ./survival
Maybe i was in the wrong directory?
Note: i have an raspberry pi and am not pi but can use sudo

When this thread started years ago we were still on Ubuntu MATE 16.04 LTS which was using the Broadcom driver from Raspbian, so ./survival just worked. The modern distros ought to use Mesa GL/GLES so you really need the helper script that loads "mcrpi-wrapper" via LD_PRELOAD.

Vince's blog above is now 404, but Gubba Monster posted instructions for setting up the script here: https://www.raspberrypi.org/forums/viewtopic.php?f=78&t=275359

That how-to is for Raspbian but if you already have non-survival working on Ubuntu MATE it should be sufficient there too, and your username need not be pi.