Netbook goes to Sleep when booting and shutting down

I have an Acer Aspire One netbook with UM 16.04 installed. The current issue I have is that the PC goes to sleep twice during the boot process. Once fully booted there are no issues until it is time to shutdown or restart. Then again during the shutdown process the PC goes to sleep. Any suggestions are appreciated.

Hi @jaybo,

I have had something similar with an old notebook recently, solution, choose a lighter version of Linux for it or maybe PCLinuxOS which I can recommend!. :smiley: Anything I tried Ubuntu based had the same problem!. :thumbsdown:

PCLinuxOS looks interesting, I will give it a try.

Still curious what is triggering the sleep mode as all runs just fine once boot is complete/

Try this
system> preferences> screensaver> power management> on ac power> set both options to never

That was one of the first things I tried with no luck. Just checked again and the never setting is still checked for both. I have this problem when on battery and AC power.

Try disabling sleep mode

sudo systemctl mask

to re-enable sleep mode

sudo systemctl unmask

1 Like

Hi @anon42388993,

this is an echo of my problem here:

1 Like

I should point out that there is a Mate version of PCLinuxOS!:

I tried:
sudo systemctl mask

Then hit upper right shutdown button to restart. System did not restart but presented the login menu as if it came out of sleep. I relogged in. Now the soft power button (upper right hand corner of screen) no longer works. Ctrl-del to shut down, same issue with login screen. I then forced shut down with the hardware power button, system now boots without going to sleep. However, the soft power button no longer works and I lost my network, both wifi and ethernet.

I then re-enabled sleep mode:
sudo systemctl unmask

System now reboots and shuts down as before going into sleep mode. Network was also restored.

I noticed that. However, there is only a 64bit version. I did try the live cd and got a message that the kernel does not support i686.

Yes I was also looking for a 32-bit version of this distro and did not see it any were

Hi @Robgoss,

I think they only have a 32 bit version of LXQT?:

As far as I know, all other versions of PCLinuxOS are 64 bit only!. :smiley:

Really that’s strange I would think they would have both. But thanks for letting me know

1 Like

There are system hooks, try mixing it up.

sudo systemctl mask

and use "unmask" to restore.

I know Wolfman has been down this road, but I also wonder if acpi could be involved. An example:

In /etc/default/acpi-support you can set SUSPEND_METHODS="none".

Do not attempt to suspend/hibernate. Set SUSPEND_METHODS="none" to
disable suspend/hibernate handling in acpi-support.

I do not own a netbook so this is no more than guess work on my part.

Good luck

Same results as using:
sudo systemctl mask
Even lost network again.

Didn't notice any difference.

I do appreciate all of the suggestions.

Hi @jaybo,

I pulled my hair out when I had this problem, I would try the LXQT version of PCLinuxOS myself!:

Good luck. :thumbsup:

Solution identified in Some problems with Acer Aspire ONE D150-1 Bk and UBUNTU MATE

Just update the the bios.

1 Like