Pluma open system file as root reboots

I used LTS22.04 .1 and could open with pluma /usr/applications/*.desktop as root.
After recent upgrades still can do it.

A new install of ubuntu-mate-22.04.3-desktop-amd64.iso creates a system where if I try to open these files or other configuration files from /etc direct with pluma or from caja - open with another application and select pluma, the get a black screen, then the login screen.
The system was just standard installed without any customization.
As user open Caja and in folder /usr/share/applications/AboutMATE right click and try open with Pluma
Session terminates and get at login screen.
All without any polite message about cause and which component does this.

I would like to know what produces this and how to restore normal behaviour.
I don't understand why this behaviour was introduced as can always edit those files as root with nano.

Thank you

1 Like

Welcome @mate-user to the community!

Thank you

I wonder why could not find other mentions about this issue.

1 Like

I tried to open /usr/share/applications/AboutMATE with pluma, it shows me Read-Only

1 Like

It opens normally here also. 22.04 LTS MATE Pro enabled

However, I note that I have recently had a huge number of desktop exits back to login splash screen, just as you describe. I have not, as yet, found any common factor, though many have happened from opening a web page in a browser, which seems an odd place to suddenly have instability.

1 Like

Hi, @charles-nix and @mate-user :slight_smile:

There are several reports, here in the Ubuntu MATE Community discussion forums, of computers that have an "Intel HD Graphics" card running Ubuntu MATE 22.04 LTS ("Jammy Jellyfish") where the graphical session "crashes" leading to a blank screen / black screen with a blinking cursor that then leads again to the Ubuntu MATE login screen. The good news is that in one of those discussions - Ubuntu Mate 22.04 auto ending Sessions when I do something specific - the user @esan_br (Elias Andrade), that has a "Dell Latitude E6410" with an "Intel HD Graphics" as its Graphics card, solved the issue that was happening to him (MATE crash that took him back to the login screen), in "Ubuntu MATE 22.04 LTS" ("Jammy Jellyfish") by:

1 - Creating a file /etc/X11/xorg.conf.d/20-intel.conf

2 - Putting the following content in that file:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"

3 - And then rebooting the computer.

Link to that post from @esan_br that he wrote on 1st October 2022:

In that same discussion, the user @Ygor6889 (Ygor Oliveira Silva), that also has a computer with an "Intel HD Graphics" video card, says that @esanbr's solution worked for him as well:

So, @charles-nix and @mate-user : if your computers also have an "Intel HD Graphics" card, it may be worth a shot to create that /etc/X11/xorg.conf.d/20-intel.conf file with the content that I mentioned above to see if that solves the issue in your computers. Please, reply later again, in this same topic where we are now, to tell if that solution also worked for you (or didn't work), as it can be useful for other people that are having the same problem.

I hope this helps :slight_smile:


I'll reply and give my thoughts, but I'll suggest reading what others have provided first.

Ubuntu-MATE is a flavor of Ubuntu, thus there are some differences when contrasted with Ubuntu Desktop. One is the kernel stack being installed; with 22.04 & 22.04.1 ISOs installing and using the GA kernel stack by default (Ubuntu Desktop 22.04 defaults to HWE for all ISOs).

You then mention

where 22.04.2 & later ISOs (thus 22.04.3) install using the HWE kernel stack by default.

The installed kernel stack can be changed post-install, but 22.04/22.04.1 media of Ubuntu flavors will install with different kernel stack defaults to 22.04.2/22.04.3/22.04.4 media.

This different kernel stack means different kernel modules are used (kernel modules being commonly referred to as drivers); so install media can matter.

The official docs are where the Ubuntu flavors match Ubuntu 18.04 LTS and earlier in regards ISO defaults.


@ [pavlos_kairis]
It is correct:
[H10:~]$ ll /usr/share/applications
total 1132
-rw-r--r-- 1 root root 125 May 19 2016 apturl.desktop
-rw-r--r-- 1 root root 14114 Jan 26 2022 atril.desktop
-rw-r--r-- 1 root root 459 Feb 1 2021 ayatana-settings.desktop
-rw-r--r-- 1 root root 7551 Dec 19 16:22 bamf-2.index

I use
as user . lroot to get a terminal for root from which can start GUI applications with root privileges
-rw-rw-r-- 1 l l 129 Aug 3 10:24 lroot
[H10:~]$ cat lroot
login as root
sudo cp /home/l/.Xauthority /root/.Xauthority
sudo chown 0:0 /root/.Xauthority
exec bash -c 'sudo su -l -w DISPLAY'

User l has sudo rights for ALL without password
There are several .desktop files that I use to create or modify.

With the problem install when try to open as user or as root get at login prompt.
In working version as user can open with Pluma but cannot save as have only read rights.

I also had issues lately with firefox.
It looks like there were introduced some security policies that create problems to desktop users, like long delays, not opening local .html files and other.

@ricmarques, you made me realize that I have been conflating two different "crashes" in my mind. What is happening on my office machine (Radeon graphics) is limited to a single piece of software (browser) randomly when seeking a new web page.

But the crash back to login screen was happening on my laptop working from home last week. And I strongly suspect that is Intel HD. I will check that solution out.

@guiverc, for information, I am still on the GA kernel 22.04 currently 5.15.0-92-generic. And I read the HWE is currently at 6.2, and soon to be 6.5. Your comments on how that works are interesting. It looks like regular Ubuntu is leaving the LTS concept. I mean, if the kernel is now rolling release, what is left to be stable for long-term support. If I wanted rolling releases, I would just follow the regular rolling release schedule.


Ubuntu 22.04 LTS HWE is at 6.5

linux-image-generic-hwe-22.04 | | jammy-security | amd64, arm64, armhf, ppc64el, s390x

having been at that for more than a week now if I recall correctly (6.2 being from 23.04 which is EOL), or about four days after it appeared on 22.04.04 dailies (-proposed was enabled).

Ubuntu introduced the HWE concept of kernels more than a decade ago, ie. if you check the wiki documentation link it goes back as far as Ubuntu 12.04 LTS, with Ubuntu-MATE following the identical standard with 22.04 that Ubuntu 12.04 LTS Desktop did.

It allows desktop users with newer video cards to benefit from later kernel features and still be on the recent LTS release (and not being mandated to always use the latest release which is usually a non-LTS).

Ubuntu has given us a choice of kernel stacks; more choice to me at least, is a good thing.

1 Like

Found the .iso from which initially I installed LTS22.04.
In casper.log find Ubuntu-MATE 22.04 Jammy Jellyfish Release amd64 (20220419)
I made new installs without any updates.
And guess what?
The system generated behaves as expected.
pluma as user opens .desktop files but does not permit modification, as expected according to file permissions.
pluma as root opens .desktop files and permits modification, as expected according to file permissions.
pluma as user instance sees that the file was modified and asks for reload.
The initial .iso vanished from all mirrors investigated. On most of them can access only version .3 .

I found this install on a CF card on which added a partition at end to store files and information to assist installation.
GPT partition table was modified, so cannot get the image of original .iso.
Can only mount it and other iso-s and find differences at file level.

After update- upgrade --no-install-recommends it still works correctly as expected.

From that ISO date, that will be the original 22.04 ISO which will install & use the GA kernel stack.

I have it locally too (along with other milestones etc), ie.

-rw------- 1 guiverc guiverc 2.8G Apr 19  2022 /de2900/ubuntu_mate_64/jammy-desktop-amd64.iso.2022-04-19
-rw-rw-r-- 1 guiverc guiverc  66K Apr 19  2022 /de2900/ubuntu_mate_64/jammy-desktop-amd64.manifest.2022-04-19

The 22.04.1 ISO of Ubuntu flavors also contain (& will use by default) the GA kernel stack, however as has been done for over a decade now, all 22.04.2 & later ISOs will default to the HWE kernel stack for Ubuntu Desktop & flavors.

You can use HWE kernel stack media & post-install switch to the GA kernel stack, search for "To downgrade from HWE/OEM to GA kernel:" in the doc, and you'll also note in that doc that multiple kernel stacks can co-exist too (ie. it recommends you test the stacks before removing the unwanted stack; there is no requirement to remove though; you'll just use a tad more disk space & have a little more bandwidth used at upgrades as both will get GA + HWE and OEM if installed will be updated).

There are extremely few differences between subsequent re-spins of LTS releases, as evidenced in a Ubuntu 22.04.3 LTS release notice

As usual, this point release includes many updates and updated installation media has been provided so that fewer updates will need to be downloaded after installation.

The change in GA to HWE kernel stack occurs at .2, and for Lubuntu (I'm a Lubuntu member so know details there readily) we also provided a newer version of calamares on subsequent 22.04 ISOs that resolved some issues we had if users installed using BTRFS, XFS if I recall correctly. Ubuntu-MATE may have had other differences too (with later respins of 22.04 ISOs), though I can't recall any.

This isn't new, Canonical only store the latest of the community flavors (there is a discussion on this on a ML currently; but I can't see it changing), though a number of users do keep older ISOs, with some even providing them for others on public sites.