Scanner worked in 15.10 does not work in 16.04

Newbie here… I have been using Windows since 3.11 but recently got tired of the bloated
windows 10 and decided to give ubuntu another try…
tried numerous flavors but have settled on MATE…
I had 15.10 setup with everything working… including my Brother MFC295CN printer & scanner…
Upgraded to 16.04 and it still worked, print & scan… but some other things seemed messed up or missing
so I downloaded 16.04 and did a fresh install… bad idea in hindsight.
Installed the exact same drivers from brother site and now the printer works but the scanner is not found.
Removed and re-installed drivers… same thing…
Any ideas or is it a bug that will be fixed ?

This does sound like a driver problem, so I think you are on the right track with that. If everything was working in 15.10, then the drivers are out there that should work. Unfortunately, there is a lot of leg work involved with finding out which driver(especially when it’s an older driver and there is no record of it). I have noticed that Ubuntu MATE took a few reboots to get my graphics drivers sorted out after I updated today, so hopefully, if you sudo apt-get update then sudo apt-get upgrade, and reboot a few times, it will start ‘magically’ working again.

It took 5 reboots and some messing with the Nvidia driver software to get things sorted out for me.
I know graphics and printers are completely different beasts, but hopefully you will have just as easy a time getting your drivers going again.

Check in the System menu, Preferences, in the Hardware and check to see if the proprietary driver for your printer is there and has been turned off(or unchecked). That’s what happened when I updated. The system will sometimes reboot to its default drivers, and you will need to turn them back on and reboot again and maybe again.

Hope this was useful, even just so you know people are reading these.

Hi @repsolal,

have you checked out their website?:

Have you installed Synaptic and done a search for “brother” in it?. :smiley:

sudo apt-get install synaptic

1 Like

Synaptic shows lots of entries for brother software… looks like drivers are installed

system preferences , additional drivers = shows no proprietary drivers are in use

1 Like

Throw caution to the wind and install any Brother packages you find in Synaptic and see if that works!.

Don’t forget that 16.04 is still in the dev stage so not everything may work as it should!. :smiley:

1 Like

i got to agree with wolfman, without being able to see the system, i would recommend downloading all the ‘brother’ drivers. If the additional drivers settings have no propreitary drivers listed then that means either the ‘brother’ drivers are not installed, or the “brother” drivers are not proprietary. Occasionally, when booting, the drivers may fail to load and will only need a reboot.

if they are not proprietary, then they can be changed by any developers(and this may have happened) and you may need to reload the original drivers from the manufacturer.
Try not to get upset if things have been changed by the developers, especially with a beta version, and especially with a minimized beta version like UbuntuMATE. In order to keep an OS small they will get rid of anything that may not be in use anymore and won’t put proprietary software, so it is possible that your drivers are no longer included. It does leave us looking for our own solutions. I’m not sure how popular Brother products are, but if you have a printer that is rare or old, or even worse one of a kind and old, then you’ll probably have to find your own drivers anytime you do a clean reinstall. Shouldn’t be a problem with the upgrades, but you might want to keep a copy of the drivers, just in case.

In both instances I used the drivers from Brother site which were specific to my printer / scanner
and installed them the same way… they worked fine in 15.10 but scanner does not work in 16.04
so I dont see how it could be the drivers ?

Hi @repsolal,

either revert back to 15.10 or wait until there is a fix for 16.04, that's all I've got; sorry!. :frowning:

Hey repsolal,
Have you had any luck with this issue?
I have had the same problem with both my brother printers. They have worked on 14.04 and 15.10. Something has changed. I noticed scanner wasn’t in user groups after installation. I contacted Brother and they gave me these unsuccessful commands (although scanner is in user groups now):
Copy the following files under /usr/lib64/ to /usr/lib/.

As root please run the commands below.

cp /usr/lib64/ /usr/lib
cp /usr/lib64/sane/ /usr/lib/sane
cp /usr/lib64/sane/ /usr/lib/sane
cp /usr/lib64/sane/ /usr/lib/sane
cp /usr/lib64/ /usr/lib
cp /usr/lib64/ /usr/lib

How do we go about filing a bug report to get this fixed?

Have you tried both Simple Scan and Xsane?. :smiley:

Having the same issue with a Canon N1240U on my wife’s computer :frowning:
Any solutions so far?

Xsane and SimpleScan both find the scanner, but doing a preview only yields a black page, the light never turns on and the scanner head never moves, but the preview image shows a black bar growing downward as the % complete counts up.

The scanner has not died, it works wonderfully using the commercial VueScan software on my computer, but this is too advanced for my wife’s needs. Xsane and SimpleScan behave on my computer, same as they do on hers.

I think it could be a problem with power save for some usb-devices.
With my Canon Lide 25 i had the same problem.

This solution works for me:
Go to the file tlp. Path /etc/default/tlp . You need to have writing rights.
You will find the line USB_BLACKLIST=
Search for it. Here it’s line 178.

Here i wrote the USB-ID after USB_BLACKLIST. Then remove the #-sign.
Like this:

The USB-ID you will get with lsusb in terminal.

Save the file and re-plugin your scanner. Perhaps it’s working now.

(Sorry for my english, but i am from germany :smile: )


This solution works for me:
Go to the file tlp. Path /etc/default/tlp . You need to have writing rights.
You will find the line USB_BLACKLIST=
Search for it. Here it's line 178.

Thank you so much! Worked for me too.

Its depressing now much arcane knowledge is needed to make things work. Without forums like this, and Google Linux would be unusable for most people.

"power management" has wasted so much of my time and effort over the years it'll never break even in "energy savings". Don't get me started on the very arrogant "screen blanking" systems and protocols -- if I want my monitor to not show anything I'll turn it off! If its on I want to see the image when I look or it would be turned on! /RANT OFF

1 Like

Is this solved for you too @repsolal?. :slight_smile:

Thank you for pointing on the problem. It seems this is causing it.

I checked it by starting simple-scan and instantly pushed scan document while scanner is doing startup. With this I am able to scan 1 page without problem.

Unfortunately I am using my Canon CanoScan N1240U/LiDE30 on 'any' USB port, while switching between Mate and Win7 at the moment and it's defenetly not supported with Win7 any longer. So, is there a solution to get rid of the USB pausing signal anyhow which USB port I'm using?

Thx in advance!

I’m not sure I understand your problem. You “blacklist” the device, 04a9:2220, then it doesn’t matter which USB port its plugged into.

Simple-Scan saving to multipage *.pdf files is just perfect for what my wife needs a scanner for, I’m really impressed by the ease and quality of the results!

I used this trick for my Canoscan FS4000 film scanner – not supported by Sane but is by the commercial VueScan software. I had problems but while troubleshooting I used it and the 32-bit VueScan in Virtual Machines (Windows 2000, Ubuntu 12.10) where it worked fine and isolated the issue to the 64-bit VueScan code and filed a bug report.

Ah, ok, thx specifying the solution. Actually I didn't make the changes yet, because I thought I have to choose one USB port only for scanner. So Adress 04a9:2220 will just listen to any USB port. That's it, thx! Will do as soon I switch to Mate next.

I can confirm I had a problem with the Canooscan N1240U/LiDE30 scanner on Ubuntu Mate 16.10.

To resolve this I issued the following command to get it to work:
echo USB_BLACKLIST="04a9:220e" | sudo tee -a /etc/default/tlp

Why does it get blacklisted?

Please mark your post as solution. Worked perfectly for me, found USB-ID with lsusb and wrote the number into tlp file.
Thx for your support!

This was the requested solution for me:

# Exclude listed devices from USB autosuspend (separate with spaces).
# Use lsusb to get the ids.
# Note: input devices (usbhid) are excluded automatically (see below)
# USB_BLACKLIST="1111:2222 3333:4444"