Skype sound not working well - how to change microphone settings?


I’m brand new to these boards, to Ubuntu Mate, and to GNU/Linux. I’d appreciate it if someone could help me out.

I installed Skype through the Software Boutique. The chat feature is working fine, and I can make and receive calls as well. Though I can hear the other side, the other side can only hear me very faintly (including on Skype test call), something I assume is related to the microphone settings? When Googling this issue, I get some solutions for Ubuntu, but not Ubuntu Mate.

What do I do next?

Thanks for your help!

Welcome @Kittywaving

What you describe can be caused by:

  • A sound settings problem on the other side or on your side
  • A skype settings problem on the other side or on your side
  • A soundsystem problem on your side
  • A driver problem on your side

In any case, I think any proposed solution for Ubuntu should work for Ubuntu MATE, since the components I described are in the Ubuntu base system.

However, while you parse the results of your Google searches, you have to consider how old they are.
A solution for Ubuntu 12.04 might not work on Ubuntu 16.04

What OS is installed on the other side?


1 Like

Thanks for the welcome!

The other side was using Mac OS in this case, however, I got the same results with Skype Test Call - you record a message and it plays it back to you - so I am pretty sure the issue is on my side. I could hear the recorded message very, very faintly. I assume it is caused either by a sound setting problem on my side, or a driver issue. I’m ehm, not that tech savvy and a bit lost right now. :slight_smile:

You can access the sound settings through System -> Preferences -> Hardware -> Sound.
In the ‘input’ tab, check if you can tweak the volume and if that changes things during the skype test call.

Nope, that doesn’t change anything… :frowning:

I since downloaded PulseAudio and messed around with the input settings. Still nothing…

Have you gone through the post install setup? (Welcome Splash screen -> Getting Started -> Drivers & Firmwares)

1 Like


I also downloaded PulseAudio and Alsamixer. I can now make Skype calls and be heard, but only faintly: if I adjust the input settings on those two, they go down again automatically immediately after. Any idea how to fix that?

Hi @Kittywaving,

does this help?:

1 Like

Sure does! Thank you!

Talking to people on Skype now, they say that they can hear me but also that the sound has a “metallic” quality to it. I wonder if there’s anything else I can do to improve the sound some more.

1 Like


glad it helped :thumbsup: , as far as improving sound goes; try installing the following package via the terminal (Ctrl + Alt + t), log out or restart after installing the package:

sudo apt-get install libsox-fmt-all

1 Like

no, that’s usually a result of limited bandwidth

Hi @Kittywaving,

don’t turn the microphone (input volume) to 100%, about 50 - 60% is enough I find!:

1 Like

I had Windows 8.1 previously on the same computer, and the sound on Skype was fine. This leads me to believe that it is not a bandwidth issue.

Thanks! I’ll try that right now.

1 Like

in skype there’s an option to let Skype automaticalyl adjust the sound and mic levels, in the sound options, is that checked or not?
I am using it on MATE ffrom 2 different distros (openSUSE and Ubuntu) and have no issues… I can’t replicate your problem.

1 Like

Hello again,

After installing yesterday’s update, the mike is now again not working at all. Any idea what I might try to fix it this time?

I am using a Lenovo G70-70, in case that is of any relevance; just from searching around the web for a solution, both when I initially started this topic and now, it appears that a lot of people having similar issues are using Lenovo computers.

Hi @Kittywaving,

try using the following terminal command (Ctrl + Alt + t):

sudo apt-get install libxine2-all-plugins

See also:

1 Like

Thanks. I just did that and the mike still isn’t working.

FYI, I came across this earlier today:

And did this:

If your microphone still does not work in apps, try recording by running the following command in a terminal window: arecord test.wavand speaking into your microphone. To stop this command press Ctrl+C.This will test basic recording functionality by creating test.wav in your HOME directory. Open this file to determine whether you successfully captured audio when using the ‘arecord’ command. This may not work if the system has not detected your input device as default. If this fails, it is unlikely that other applications can successfully capture audio without further troubleshooting. In some cases you may need to configure your ALSA setup or try testing with Audacity as per instructions above.’’

This showed that it is not just Skype, but in fact the microphone is not working in general.

Any idea what to do next? And what is “Audacity”?

Also did this:

This is what I had to do to get the internal mic to work on my Acer Aspire 5745G:

Install pavucontrol >> sudo apt-get install pavucontrolRun sudo pavucontrolGo to the “Input Devices” tabClick the lock icon to unlock the channelsSet the right-front channel to silence