Startup error with xserver-xorg-core

I've installed Ubuntu mate 15.10 on my pc but from the first startup I have this error:


run "dpkg" per the update guide and see if that fixes the problem for you (a network cable connection is required!):

if I type “dkpg” on my terminal it appears:

  • use dpkg --help …
  • use “apt” or “aptitude” …
  • use dpkg --force-help …
  • use dpkg-deb --help …


you have to boot into advanced mode > recovery mode (2nd option in the menu list) via the GRUB menu when you boot, please read the guide!. :smiley:

I think to have another problem!
When I boot my pc I don’t have any grub but only a grey screen.

Press the "Shift key" as soon as it starts booting!.

See this also:

I made also this try but when I enter in advanced mode an empty grey screen is showed.
I have a grey screen with “Grub Menu” title and “b: boot, e: edit, c: command-line” in the bottom.
In the center of the page I have an empty field

Could grub be repaired with boot-repair.

1 Like

Did you follow this advice when creating your bootable media, it sounds to me like you have a corrupt install?:

I tried to fix it by typing
sudo grub-install /dev/sda which produced the output:

Installing for i386-pc platform.
grub-install: Warning: The sector 32 is already in use by "FlexNet" program is skipped. This software may cause startup problems, or others, in the future. Inform authors and warn them not to store data in the range of MBR ..
Installation complete, no error reported.

So, the problem still remains and now, if I press "shift key" the screen remains grey

Read this:

I followed all steps in this post thanks to last wolfaman’s post.
I repaired the grub but I cannot still view it on pc boot.
If I press shift key it doesn’t works (it worked only one time, after to have made mbr backup).
Is there a way to reinstall OS whithout lost my data and my installed softwares?
When I installed os I choosed a different partition for home

There you go and make sure you put GRUB on the device "/dev/sda":