Terminal ignores size with multiple monitor setup

My monitor setup is such that I have a monitor mounted over top my laptop. The monitor is 1920x1080 and the laptop is 1280x800. So in terms of position, the monitor has a bit of extra room on the left and right side of the laptop.

In terms of xrandr, the positions are setup as:
xrandr --output eDP1 --auto --pos 320x1080 --output VGA1 --auto --pos 0x0

When I open Mate Terminal, it opens up as a skinny terminal at 33x24. If I go to Edit >> Profile Preferences the default is set to 80x24. If I launch Mate Terminal through the command line with mate-terminal --geometry=80x24 the same issue occurs. It is opening at 33x24.

One thing I noticed with my monitor at top is it’s configured weird. When I move a window around, galculator for example, there are snap points in the middle of the monitor. It feels like the snap points are at the edges of the laptop dimensions. So one snap point is at 320 pixels and the other is at 1600 (320+1280).

Note, the xrandr command is just to show the setup. The same issue happens if I use the built-in Display preferences as well as if I use arandr.

Another note, if I have the monitor setup to be on the right, the terminal opens at the correct size.

It seems the monitor position and snap points are affecting the terminal size. Any ideas on how I can fix this?

1 Like

I can confirm the display snapping issue.
I’ve noticed that a while ago and I’m ashamed to say I didn’t file a bug report.
It seemed to only happen in specific display configurations, as @FrankR mentions, when using an external monitor connected to the laptop . As in, moving the relative positions of the display a little would make this bug disappear.
I’m not sure what component is responsible for this. :/
The terminal size stuff is new though, I hadn’t noticed that.

One other thing I’d like to note from my tinkering. If I align the left edges on the top and bottom displays, the window management will maximize windows underneath the top panel. The borders of the display are fine in terms of mouse movement, it’s just maximizing seems off.

I noticed that if I have the top and bottom displays un-aligned, as in my original configuration of the bottom being 320px to the left, I won’t have this issue. Windows will maximize properly in the space between the top and bottom bars.

I did a quick search and seen this bug report. Seems like this specific issue has been around in Mate for a while.

Hi @FrankR,

could it also be something to do with your GPU drivers?. :confused:

I’m up to date on everything. It’s a basic Dell laptop with Intel. No Nvidia or AMD.

1 Like

I don't think so. My best guess for now is a bug in Marco.
@FrankR , can you reproduce this with Compiz ?

Apologies for the late response!

I just changed to Compiz from Macro and it seems to be working as expected. I can maximize windows without the title bar hiding behind the panel. I can launch the terminal at the proper size while being able to move it freely on the top monitor.

So far, everything seems fine under Compiz.

Thanks for checking it out.
Can you please contribute your exact monitor configuration for a future bug report?
Edit: in a configuration where the Marco bug occurs, I mean.
I think the output of:

xrandr -q

should provide the desired information.

Just an update regarding compiz. When I minimize a window, I can’t click on another window to get focus.

For example, I have a maximized terminal window and a maximized Chrome window. When I am in Chrome, I minimize it to go back to the terminal (in this case I was going to run your xrandr command). Once Chrome is minimized I can’t interact with the terminal. It’s displayed, but the mouse will not provide focus to the terminal. In order to get focus, I have to click on the terminal in the bottom panel.

Is this a known issue or something I have to configure? I’m going to try and look at compiz settings and see if I can get to the bottom of this. I could see not getting focus being a setting, but not even being able to click with the mouse to get focus seems more like a bug.

As for the xrandr output, here is my configuration.

Screen 0: minimum 8 x 8, current 1920 x 1880, maximum 32767 x 32767
eDP1 connected primary 1280x800+272+1080 (normal left inverted right x axis y axis) 303mm x 190mm
   1280x800      59.99*+  40.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
   640x400       60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
VGA1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1024x768      75.08    60.00  
   800x600       75.00    60.32  
   640x480       75.00    60.00  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Check out point #6 here:

1 Like

That was it! I’m now able to use my mouse to regain focus. Perfect. I was more than likely going to go back to Marco if I couldn’t figure this out.

Did you need anymore information regarding the Marco issue?

I don’t think so, but maybe @monsta or @Wimpy will weigh in.

Was there a bug logged for this and if so, is there a link where I can follow the progress?

I really dislike using compiz. Everything feels broken where I’m constantly searching for fixes and often times not even finding fixes. I would like to follow the bug so I know when I can switch back to Marco.