Testdriving daily build 24.04 (Noble Numbat)

A few days ago I installed (still pre pre pre alpha) Ubuntu-Mate 24.04 Noble Numbat on my ageing Thinkpad T420.

It was quite stunning to see it install without a hitch an running rock solid as if it was a late beta. Ofcourse the Boutique is not yet populated and the like, but browsing/surfing, libre office, multimedia, networking etc. just work fine.

Sure there are some old small unimportant papercuts remaining from older versions at the moment, like the old wnck crash when previews in the windowselector are enabled (which I don't use) and the ayatana-clock-indicator day and month switched in my locale (nl) when weekday is also enabled (so I use the old date/time applet), but those hardly count as showstoppers.

There is a new small, and only cosmetic, papercut where the fields in the workspace switcher have the wrong aspectratio (it ignores the width value) which is also not a big deal because it just works anyway.

But I also found some things that have been fixed and/or improved:

  1. panel icon no longer stuck on plank after panel actions
  2. startup applications has gained a maximize button (which is absolutely a welcome improvement)
  3. libmateweather is up to date (=works without needing patching)
  4. faster boot, at least on this laptop

Ofcourse I pimped it a bit, tailored to the black/red T420 :wink:
(using the jammy version of the "ambient-mate-lah7" ppa)

Thus far I'm pleasantly surprised (i.e. highly impressed) and eagerly following the developement of this already rock solid pre-pre-pre alpha version.

DISCLAIMER (BEWARE!):
DO NOT INSTALL THIS VERSION YET on a computer that you need for your daily work or the like. It is still in developement.
I can testdrive this because my Thinkpad has no further purpose at the moment so any crash or diskfailure is not a problem.

4 Likes

Today, after the latest update, lightdm doesn't work anymore so you can't graphically login at the moment.

I guess that at the moment devs are working to upgrade the graphical shell (Xorg + lightdm) so some inconveniences are naturally unavoidable.

For those who are testing 24.04 at the moment: To work around this temporary inconvenience, press [Ctrl][Alt][F1] , login and use the command "startx"

For the ones that use AMD GPUs:
There is at the moment a possibility that on some AMD GPUs the graphical shell won't start at all or crashes. The telltale sign is this message during boot:

================================================================================
UBSAN: array-index-out-of-bounds in /build/linux-xR9R4C/linux-6.6.0/drivers/gpu/drm/radeon/radeon_atombios.c:2717:34
index 16 is out of range for type 'UCHAR [1]'
================================================================================
UBSAN: array-index-out-of-bounds in /build/linux-xR9R4C/linux-6.6.0/drivers/gpu/drm/radeon/radeon_atombios.c:2705:39
index 2 is out of range for type 'ATOM_PPLIB_NONCLOCK_INFO [1]'
================================================================================
UBSAN: array-index-out-of-bounds in /build/linux-xR9R4C/linux-6.6.0/drivers/gpu/drm/radeon/radeon_atombios.c:2715:55
index 1 is out of range for type 'UCHAR [1]'
================================================================================
UBSAN: array-index-out-of-bounds in /build/linux-xR9R4C/linux-6.6.0/drivers/gpu/drm/radeon/sumo_dpm.c:1495:39
index 2 is out of range for type 'ATOM_PPLIB_NONCLOCK_INFO [1]'

Bugreport is here in case you want to push the "affects me too" button or to add some helpful comment :slight_smile:

EDIT:
I discovered that the Xorg crash had nothing to do with the errors above. After some fiddeling Xorg ran just OK despite the boot errors.

2 Likes

For the people who wonder how a T420 can have a E-350 APU:
It doesn't :slight_smile:
I decided to test/install 24.04 also on my ASUS F3T (nVidia) and on my crappy Toshiba (which is the one with the E-350 APU)

(b.t.w. all three refused to start Xorg via lightdm just after an update, see previous message.)

2 Likes

For those of you who are also testing Ubuntu-MATE 24.04 LTS pre-alpha:

The reason that the graphical login is not working at the moment is because of work that has to be done on arctica-greeter. Changing arctica-greeter temporarily to slick-greeter will give you the graphical login back:

sudo apt purge arctica-greeter
sudo apt install slick-greeter

When arctica-greeter is ok again you can change it back:

sudo apt purge slick-greeter
sudo apt install arctica-greeter
2 Likes

Hurray ! :slight_smile:
Ubuntu-MATE 24.04 LTS (Pre-Alpha / in developement) running smooth on two pretty ancient laptops :slight_smile:

ASUS F3T (2005):

CPU: dual core AMD Turion 64 X2 Mobile TL-52 (-MCP-)
speed/min/max: 800/800/1600 MHz Kernel: 6.6.0-14-generic x86_64 Up: 39m
Mem: 761.6 MiB/2.87 GiB (25.9%) Storage: 111.79 GiB (17.6% used) Procs: 180
Graphics: NVIDIA G72M [Quadro NVS 110M/GeForce Go 7300] driver: nouveau

Toshiba Sattelite C670D-10H (2011):

CPU: dual core AMD E-350 (-MCP-) speed/min/max: 799/800/1600 MHz
Kernel: 6.6.0-14-generic x86_64 Up: 34m Mem: 1014.4 MiB/5.4 GiB (18.3%)
Storage: 298.09 GiB (6.3% used) Procs: 187 Shell: Bash inxi: 3.3.31
Graphics: AMD Wrestler [Radeon HD 6310] driver: radeon v: kernel

2 Likes

Update today brought an updated network manager and a new kernel

It broke my networking on the ASUS F3T :face_with_raised_eyebrow:
Both wired and WiFi, and now:

  • A cold boot gives me a working network
  • A reboot (warm boot) gives me no network at all
    Rebooting with the older kernel didn't solve the problem.

Very strange, because on the T420 and the C670D all is well :thinking:

With all networking down I tried:

  • ip a
    which shows both networkadaptors DOWN
  • sudo ip link set dev wlp1s0 up
    does not give an error but even so does not bring the network up.

After a cold boot and with networking up I tried disabling Wifi, which worked, but then enabling again didn't work for some reason. Exactly the same with wired ethernet

So, I can bring the network down but can't bring it up again
I am completely baffled. :face_with_spiral_eyes:

If anyone could shed some light on this would appreciate it :slight_smile:

EDIT: The problem is restricted to WiFi, the wired problem was a bad cable :man_facepalming:

EDIT2:
After using nm-applet to disable Wifi, the Wifi becomes hardware(!) blocked
trying to bring the adaptor up
:~$ sudo ifconfig wlp1s0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill
:~$ sudo rfkill unblock all
:~$ sudo rfkill list
phy2: Wireless LAN
Soft blocked: no
Hard blocked: yes
:face_with_spiral_eyes:

EDIT3:
Starting with enabled WiFi and listing rfkill:
phy2: Wireless LAN
Soft blocked: no
Hard blocked: no

Using the hardware RF-switch to disable WiFi:
phy2: Wireless LAN
Soft blocked: yes
Hard blocked: no

Setting the switch back to its origina position:
phy2: Wireless LAN
Soft blocked: no
Hard blocked: yes

:woozy_face:

EDIT4:
Problem partly solved:
The system had blacklisted the driver that worked, so I unblacklisted it:

cat /etc/modprobe.d/blacklist-ath_pci.conf 
# For some Atheros 5K RF MACs, the madwifi driver loads buts fails to
# correctly initialize the hardware, leaving it in a state from
# which ath5k cannot recover. To prevent this condition, stop
# madwifi from loading by default. Use Jockey to select one driver
# or the other. (Ubuntu: #315056, #323830)
blacklist ath_pci

^this last line I commented out to get everything in working state again.
(the only thing that is still not working quite right is the hardware switch)

So, after all, contrary to expectation, turned out to be a driver problem.
:slight_smile:

3 Likes

6 Likes

HAHAHAAA....BRILLIANT!! :rofl::rofl::rofl::rofl::rofl:

3 Likes

ASUS F3T:
Brave-browser, when trying to change theme, starts fighting with the Xpresent compositor which results in a weird kind of truce a.k.a. system freeze.
Disabling the compositor solves this.

(This is one of the things that makes Ubuntu-MATE so special.
Disabling or enabling the compositor, on the fly, in real time, is just a few mouseclicks away. )

Another reason to disable the compositor, on this particular piece of antique when using Brave, is youtube videos.
Yes this piece of antique can play youtube videos but it gets a bit too heavy for the CPU/GPU combi (AMD Turion X2/GeForce Go 7300) when the compositor is also enabled.

Keep in mind that you don't need to do this on more modern systems with more capable GPUs (probably anything build after 2012): this F3T laptop is almost two decades old so it is a miracle it runs all this stuff from a pre-alpha 2024 OS anyway. :star_struck:

1 Like

Toshiba Sattelite C670D-10H (2011):
I forgot to tell what's so special about this piece of junk.

This low-budget laptop was generously donated to me by a lovely lady with the lovely, almost romantic, words: "get this piece of crap out of my sight, I hate it !!"

Now I understand this because the poor laptop, which wasn't particularly fast to begin with, had endured some kind of "electrical accident" which had resulted in a blown up battery, a blown up harddisk and some random blown up I/O circuitry in between so it didn't do that much anyway anymore.

It was actually amazing that, after connecting a replacement disk that it came back to life, although pretty crippled: The speed of the I/O was only half its specs.
Swapping the harddisk out for an SSD didn't make any difference speedwise so I left the old replacement "spinning-rust" device installed.

Therefore testing Ubuntu MATE 24.04 on this device can immediately reveal some I/O bottlenecks, including any bloat or overengineering :grin:

Since its I/O is crippled but its RAM is 6GB , I did set vm.swappiness = 5 to keep most of the desktop loaded. It did make the system much more responsive :slight_smile:

2 Likes

More info about the "UBSAN: array-index-out-of-bounds" error

This error always prop up with AMD drivers on newer kernels.

Since the AMD drivers use variable sized arrays, this error is actually a false positive.

See this reference where Alex Deucher (AMD Linux driver developer) explains a bit. There is also some example code.

EDIT: Should be fixed in kernel 6.7

2 Likes

T420 is my favorite of all time. The only thing that is annoying is the screen, but I have learned to accept its limitations.

1 Like

Reinstalling Brave-Browser

Brave-Browser did let me know that there is a new version it can't update to so a reinstall was necessary.

I followed this official reinstall procedure:

Which induced the following problem:

So in the file /etc/apt/sources.list.d/brave-browser-release.list
i changed:

deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main

to

deb [arch=amd64 signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] https://brave-browser-apt-release.s3.brave.com/ stable main

which solved the problem. :slight_smile:

1 Like