[Tutorial] - Flash Player for Chromium and Firefox

Get pepper flash plugin
We need pepper flash plugin to get flash working under Firefox or Chromium.

There is no pepper flash plugin for raspberry pi 2 so we need to extract it from another device or download it from internet.

If you want to extract it, I wrote a tutorial for that :

Alternatively if you don’t want to extract it, you can download it :

wget http://dl.free.fr/qVkzvqSiB -O pepper-flash-v20.0.0.228-r1.tar.xz

Check the sha1 :

echo “e320d3b9003476b82576bb303c11a75291c674c7 pepper-flash-v20.0.0.228-r1.tar.xz” | sha1sum -c -

You must have :

pepper-flash-v20.0.0.228-r1.tar.xz: OK

If you don’t the archive is corrupted or hacked !

Extract and copy the files of the archive :

tar Jxvf pepper-flash-v20.0.0.228-r1.tar.xz
cd pepper-flash
sudo mkdir /usr/lib/PepperFlash
sudo cp * /usr/lib/PepperFlash


Install fresh pepper flash plugin :

sudo apt-get install browser-plugin-freshplayer-pepperflash

restart firefox and enjoy :wink:


Edit the file /etc/chromium-browser/default :

sudo pluma /etc/chromium-browser/default

Then change CHROMIUM_FLAGS= by :

CHROMIUM_FLAGS="–ppapi-flash-path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version="

Save the file.

restart chromium and enjoy :wink:



Hi, is there any reason why you can’t simply run the last command on its own?


I don’t really know much about it, but this article seems to indicate that just installing the browser-plugin-freshplayer-pepperflash package is enough.

Nathan Stanley Russell

Yes there is.
freshplayer pepperflash is a wrapper for firefox of chrome bundled flash plugin.
But there is no chrome arm version, so there is not chrome bundled flash plugin for arm too.
So I you only install freshplayer pepperflash that will not work on rapsberry pi 2 or any another arm device.
So if you are on x86 or amd64 architecture (standard computer) you don’t need that tutorial, it is only for raspberry pi 2 computers.

1 Like

Ah, of course, sorry, I didn’t read the ‘raspberry pi’ tag at the top!!

It happends, no problem :wink:

Thank you so much. :grinning: (we need that with cool shades, lol)

I have a question. I have Firefox in this raspberry Pi2 (I still wish it was twice what it is with a real FSB instead of a single USB channel, gripe). Dose this pepper dispenser thing need Chromium to work, or will the older stainless steel pepper shakers work without Chromium, lol.

Do I need to install Chromium for this flash thing to work in Firefox?

No you don’t.
I update the first post of the thread to make it better and easy to understand.

Incredibly overdue Thank you. It's been a tad buisy around here lately.

I’ve tried downloading the linked file a few times but the checksum keeps coming back as incorrect.

Is it possible to provide another link?


The link works. Maybe server was down when you tried.
Could you retry ?


Thanks for the reply. Sorry for the delay in responding, I was working away.

I still get a checksum error. If I run …

wget http://dl.free.fr/qVkzvqSiB -O pepper-flash-v20.0.0.228-r1.tar.xz

echo “e320d3b9003476b82576bb303c11a75291c674c7 pepper-flash-v20.0.0.228-r1.tar.xz” | sha1sum -c

Then I get …

pepper-flash-v20.0.0.228-r1.tar.xz: FAILED
sha1sum: WARNING: 1 computed checksum did NOT match

Any idea?

If I run
sha1sum pepper-flash-v20.0.0.228-r1.tar.xz
Then I get
0507219d064de0c7c7f4aade3074448d090cf2eb pepper-flash-v20.0.0.228-r1.tar.xz


Downloaded on a PC and the checksum was correct so have used that.

No idea why it kept going wrong with wget on the pi but I think I have it working now.

Thanks for the tutorial and making it available to download :slight_smile:

I got the same thing.
pepper-flash-v20.0.0.228-r1.tar.xz: FAILED
sha1sum: WARNING: 1 computed checksum did NOT match

sha1sum pepper-flash-v20.0.0.228-r1.tar.xz
0507219d064de0c7c7f4aade3074448d090cf2eb  pepper-flash-v20.0.0.228-r1.tar.xz

If I click the link and download it from the website and then move it to my home directory, the checksum works okay.


I am using Raspberry Pi 3 with Ubuntu Mate 16.04…

Do you happen to have the latest release version of the Adobe Flash version 22.

Because some web sites requires to use the latest Adobe Flash version.

Otherwise it cannot load the web pages.

I notice that as I use Youtube it did not make use of the Adobe Flash plugins… the browser still using HTML5…

Hello aworan. Hoping you can steer me in the right direction as I try to install pepperflash on my rasp pi 3. I have been successful in extracting the files of the archive using the terminal. However, when I attempt to follow your instructions to install fresh pepper flash plugin with the command you have listed, I get this error:

E: Unable to locate package browser-plugin-freshplayer-pepperflash

Thanks in advance.


No I don’t.
I extract flash plugin from chromebook recovery images and google didn’t update it from a month.
The last flash version available for now with the recovery image is
We must wait for an update of it.
Another way is if you know someone who have an armv7 chromebook like “Samsung Chromebook 2” you can ask him the plugin file. It must be updated.

HTML5 is use by default in modern browsers ! And it is the better way to watch videos on youtube !
You can change the configuration here : https://www.youtube.com/html5

It must work, I don’t have my pi now, I will try later tonight.

It work, try :

sudo apt-get update
sudo apt-get install browser-plugin-freshplayer-pepperflash

sudo apt-get update loaded a bunch of updates, but the second command still showed the same error.