Ubuntu MATE 18.04 Beta 1 for the Raspberry Pi is out!


#1

We are preparing Ubuntu MATE 18.04 (Bionic Beaver) for the Raspberry Pi . With this Beta pre-release, you can see what we are trying out in preparation for our next (stable) version.

Ubuntu MATE 18.04 Beta 1 is available for Raspberry Pi Model B 2, 3 and 3+, with separate images for armhf (ARMv7 32-bit) and arm64 (ARMv8 64-bit). We have done what we can to optimise the builds for the Raspberry Pi without sacrificing the full desktop environment Ubuntu MATE provides on PC. High-level features of these images are:

  • Ubuntu kernel, fully maintained by the Ubuntu Kernel and Security teams.
  • Automatic online filesystem expansion.
  • Ethernet & WiFi ( where available )
  • Bluetooth ( where available )
  • Audio out via 3.5mm analog audio jack or HDMI
  • Video out via Composite or HDMI
  • GPIO access via GPIO Zero, pigpio and WiringPi.
  • Support for Python Wheels for the Raspberry Pi.
  • Support for USB Booting.
  • Hardware acceleration:
    • fbturbo driver is pre-installed but limited to 2D accelerated window moving/scrolling on Raspberry Pi (using the BCM2835 DMA Controller).
    • VLC has hardware assisted video decoding.
    • ffmpeg has hardware assisted video decoding and encoding.
    • The experimental VC4 driver can be enabled via raspi-config .
    • Please note, the arm64 images do not feature any VideoCore IV hardware acceleration.
  • Additional software:

Read the release notes to learn more and get the downloads:


Status of Ubuntu MATE 18.04 for Raspberry Pi 3 B & B+?
#2

You mispelled it as 'amd64' for Armv8 64-bit even though it's actually 'arm64' and 'amd64' is the 64-bit x86 architecture.


#3

Thank you i will try it out


#4

Thanks, you'd be surprised how easy it is to do that and not see it :blush:


pinned globally #5

#6

I am pleasantly surprised to see that the 32-bit image boots directly from usb (ssd in this case) with no sd card inserted and no additional steps of any kind. Thanks for all of the work that went into this project.


#7

The party continues. Will be glad to test and give feedback. Thank you for the builds. sir.


#8

Noticing some minor issues out of the box upon first boot. Audio isn't working although I do not see dummy output under sound settings. Tried via HDMI and a bluetooth headset. Also, no options appear when trying to select a language for Firefox under Preferences > General section > Language & Appearance > Language. I'm using the Rpi3b+ with the armhf image. Good news is bluetooth is working on my end. And it's pretty darn efficient at not locking up thus far.

EDIT: Actually the sound works, but it seems to stutter and lag. The sound test under settings doesn't seem to work though. Nor do you hear previews of the different sound themes. And audio in Firefox is laggy, and has breaks in it even on 144p with only 2-3 tabs open.


#9

How is audio connected? Analogue jack or HDMI?


#11

I tried the 32-bit on RPi3B+ yestreday with HDMI vide and sound via a VGA converter which has a take-off for sound.
Looks good, sound works (albeit mono) but sound test doesn't.
I haven't worked out why, on network, my linux systems are visible but the Windows network isn't.
HTH
Derek


#12

During the initial install, and on subsequent reboots, the following message appears:

"Error [2.650017] Driver sdhost bcm-2835 is already registered...aborting."

The install, and the system itself work just fine. Martin indicated via Twitter that this will be addressed, but it is not a harmful message.


#13

I'm receiving under-voltage alerts from this RPi 3b+, which is odd because I've tried multiple power bricks, including a higher-end Anker power supply that is capable of providing sufficient voltage, as well as current up to 5A.

I mention this because this beta build is performing very slowly. Browsers such as Firefox and Chromium are unusable and hang the system very quickly. I get that we're talking about a Raspberry Pi 3b+, but running either browser on Raspbian is significantly faster. So, it might be a situation with under-voltage, but I'm not sure. I thought it might be worth reporting. Perhaps others are seeing a similar situation?

EDIT: As someone else noted, audio is very laggy as well. Even the simple menu alert sounds lag considerably.


#14

That is a know issue and being worked on. It is just noise, the device is being initialised twice.


#15

I need to know how audio is connected (cable) and to what. Have you used raspi-config to setup audio to suit how you have it connected? Have you checked /etc/firmware/config.txt to make sure the audio settings are appropriate for you setup?


#16

Audio is connected via HDMI.


#17

So on audio, I get an error saying that it's waiting for my sound system to respond (guessing it's an issue with pulseaudio) and I was going to ask if there were any plans to port over the SD card copier tool from raspbian. Otherwise everything seems to be working fine on the 32 bit build the 64 bit just seems a bit laggy though


#18

Just downloaded to my Pi3B+ and performed initial setup. (verified checksum)

EDIT - Update
The problems outlined below happened, but the underlying cause may be networking.
I had connected to WiFi and all appeared to be OK; IP was allocated, route looked OK, and I managed to download 3 packages until it failed on the 4th.

Networking was unresponsive, even though connection looked the same.

Using Ethernet things look much better.

I have imaged 3 SD Cards, and seem to have an intractable WiFi problem. (The same Pi with Raspbian, connected to the same WiFi, allocated the same IP works seamlessly. Routers have been reset.)


The clock showed Jan 2018, but setting did not seem to take.

I configured date through Control Centre but failed to set time.
The "Set System Time" failed "/sbin/hwclock returned 256".

Time and Date Settings was set to Manual, and informed me "NTP support is not installed" although systemd-timesyncd.service is running.

timedatectl shows systemd-timesyncd.service active but synchronised no

On restart time changes all seem to be lost, and date reverts to Jan 2018


#19

Not sure if it was PEBCAK or something else, but for whatever reason, openssh-server did not properly generate keys on installation.

dpkg-reconfigure fixed it easily

There was some other small/minor annoyance I encountered but I forget what it was...

No other issues so far, setting up the mcp2515 dtoverlay on a Sfera Labs StratoPi-CAN seems to have worked well, although I haven't actually connected the CANbus interface to a vehicle network to test that yet.

However, I do ask - given the nature of Pi power management (or lack thereof compared to most ARM-based mobile devices, there is no suspend/deep sleep support to my knowledge for Pis) - why is the notoriously-buggy Broadcom WLAN power management enabled on Pi 3 B/B+ devices enabled by default? (Not even Raspbian gets this right - they STILL try to enable it even though it is guaranteed to result in a horrendously unstable connection.)


#20

@wimpy - I installed the rpi 3B 64 tonight. The install went perfectly...PERFECTLY. Everything was working including BT. I have never actually seen that work before.

I went for my first reboot (raspi-config was supposed to resize the drive on the next reboot). I get the rainbow then black screen for about 30 seconds and then my hdmi monitor says no connection. I scanned through the config.txt. That file has a lot of content but is doing next to nothing.

I have tried to enable safe mode but the sd drive can only be mounted as read only - I can't edit it. I have seen this before. For some reason all usb drives are mounted write enabled and all sd cards are read only unless it is the actual boot drive.

Thanks for getting the Beta out. I know you worked hard on it.

@wimpy - 3 hours later - turns out it was corruption on the brand new 32GB SD card. Unrecoverable! I installed on another card and presto....we have Ubuntu Mate 18.04 running on my pi 3B


#21

That is why we have betas :slight_smile: WiFi Power Management will be disable in the next image.