Ubuntu Testing Week - Ubuntu MATE 20.10

It’s time for….20.10 ISO Testing! :clock1:

This week, the official Ubuntu flavours are coming together for another Ubuntu Testing Week, to get us ready for 20.10, aka Groovy Gorilla. :man_dancing: :gorilla: We would appreciate any and all who could help us test the ISOs, so we can find and squash issues as we continue the development cycle. :mag_right: :bug:

We strongly encourage you to test this image from a spare machine or a VM, and as always, very strongly encourage you to backup before downloading anything on to your primary system.

So, if you’re new to ISO testing, or need a refresher, here’s a quick guide!

First of all, you’ll need a Launchpad/Ubuntu One login. Go here to create one if you haven’t done so already.

You’ll want to download the Groovy Gorilla daily build here: http://cdimage.ubuntu.com/ubuntu-mate/daily-live/current/

Take a look at the testsuites for Ubuntu MATE, many of which take less than 30 minutes to complete. :clock1030:

Follow the directions in the testsuite. If it does all of those things, great! If it doesn’t, however, we need your help. Click on the link at the top of the page that reads “Report a bug against the contents of this testcase.” Sign in with your Launchpad/Ubuntu One account.

Follow the directions in the bug report, and be as specific as you can! This is a key step - an unreported bug will be an unfixed bug. :bug: :receipt:

Thanks in advance to those of you who can help, and please reply with any issues, concerns, or questions! :green_heart:

4 Likes

Can you supply a link to what is new/changed/addressed in 20.10 pls?

And while I'm here, where/how do you want issues reported? Here in this thread or launchpad or both? If launchpad (link?) how to mark them as applicable to 20.10: in title, body, some key eg. 20.10 or Groovy Gorilla, or some mix?

There is currently not a compilation of changes for 20.10 and that will not be completed til later in the development cycle. Here is the current Ubuntu Release Notes

The steps for reporting bugs can be found here: Testing and Quality Assurance. You can also follow on with comments about the bugs that you have encountered in the forums.

2 Likes

The current daily ISO's are not installing correctly.

I'd like to point out this bug and remind everyone how important performing ISO tests are for all Ubuntu and flavour users.

Also there is a problem with GRUB installation on BIOS (legacy) systems:

Big thanks to @Norbert_X and @guiverc for their continued dedication to testing.

4 Likes

I can not start GParted in two Dell laptop instances of groovy from the terminal. GParted is not listed under Applications in my Traditional panel layout and using apt to install it apparently doesn't work. Synaptic reports that Gparted is installed. Anyone else notice this in their groovy installs?

I can't reproduce this.
Installation with sudo apt-get install gparted ends successfully.
The GParted application is presented in the menus (ApplicationsSystem ToolsGParted) and can be launched from them or using terminal command gparted. Then it asks password and launches.
Tested on freshest VM installed from todays ISO and on real hardware with previously installed version of 20.10.

Typing gparted in terminal gets "Command 'gparted' not found, but can be installed with: sudo apt install gparted". Same on both laptops. I intend to install today's groovy and see if this behavior persists. Thanks @Norbert_X

1 Like

I installed today's groovy and once again got unable to install grub on /dev/sda and then an installer crash. Reported the bug once again.

After that, rebooting into 20.10 and using a terminal got "Command 'gparted' not found, but can be installed with: sudo apt install gparted ". I used synaptic to completely uninstall gparted and then used apt to install gparted. This worked to actually install a GParted that functions.

My guess is that the installer crash left bits of the live USB GParted 'installed' but not enough for it to function. Thanks Norbert_X for reporting on my problem. Both laptops are fixed.

The ubuntu daily current has not been updated since 2020-07-08 08:28
There is a critical bug which causes an install to fail when it gets to the bootloader install at the end.


I think this affects all the flavours that use ubiquity
2 Likes

This problem, or related problems with the grub2 bootloader have been around for quite awhile and devs don't seem to be doing anything to respond to the problem. Here's a bug that might be a dup that I have been "following"
https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1863434/

And yesterday in both my ubuntu 20.10 distros upgrading to what might be kernel 5.8 seemed to break the video driver??? I posted a thread here in the sub-forum and filed a bug #1890211 because it seemed to be "significant" and affected two ubuntu systems.

Thanks for the link to bug #1885414.

Bootloader (Grub) installation was failing for me even inside a VirtualBox VM, and I couldn't find bug #1885414 through apport, so I've submitted 2 bug reports on July 06 and Aug 01:

Though the installation went through when I enabled EFI support through VirtualBox settings.

Now as per the latest on bug #1885414, it sounds like the fix has been issued with Ubuntu MATE 20200805.1 ISO. I'm gonna try to install Aug 06 ISO and will post the result in here.

Bootloader installation still fails with Aug 06, 2020 ISO of Ubuntu MATE Groovy 20.10 in a VirtualBox VM.

Host OS: Ubuntu MATE 20.04
VirtualBox Version: VirtualBox-6.1.97-139689-Linux_amd64

Right when I tried to partition manually there were warnings that I never saw till Ubuntu MATE Focal 20.04

Warning #1:
"No EFI System Partition was found. This system will likely not be able to boot successfully, and the installation process may fail. Please go back and add an EFI System Partition, or continue at your own risk".

and upon clicking "Continue", installer displayed:

Warning #2:
"The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked as a "Reserved BIOS boot area" and should be at leat 1 MB in size. Note that thi is not the same as a partition mounted on /boot.

If you do not go back to the partitioning menu and correct this error, boot loader installation may fail later, although it may still be possible to install the boot loader to a partition".

I have submitted 2 similar bug reports on July 06, and Aug 01, bug report #1886580 and #1889989.

Today, I could not submit bug report from within the installation as Apport kept displaying a message, "Collecting problem information". I waited for 20+ minutes but it did not bring a window from where I can submit a bug report.

Here's Imgur album with 7 screenshots:

@Jags Desai (jagsdesai)

Installing without ESP partition seem to be currently impossible, so please allow its creation and then GRUB will be installed on legacy and/or EFI system.

The ESP partition was introduced after 18.04 LTS. For now all systems have two partitions after installation - ESP and rootfs.

So please do tests correctly - as described in http://iso.qa.ubuntu.com/qatracker/milestones/413/builds/218647/testcases/1300/results for example.

@Norbert_X

Ok. Also, just to be extra clear, "Enable EFI" was NOT selected in the VirtualBox settings, and the host machine is also with old-style BIOS (no UEFI at all).

#1: Do I have to create two small partitions, (1) EFI system partition, and (2) Reserved BIOS boot area... or just one, EFI system partition?

#2: From the link you provided, point #11 says, "Full drive space is allocated for installation"

So does manual partitioning (meaning not allocating the full drive space) blocked / not allowed anymore with Ubuntu / Ubuntu MATE 20.10 onward?

Thanks alot.

Yesterday I was surprised by two partitions too. So you are not alone with this.

It seems that testsuites should be updated to have more correct wording.
Currently

"Full drive space is allocated for installation"

means "Full drive space is allocated for installation" – ESP size.

So we have two options:

  • Default installation

    Currently the Erase disk and install Ubuntu MATE will lead to this partitioning:

  • Manual partitioning

    If you want to create manual partitioning - use Something else and create ESP by yourself:

    1. New Partition table

    2. Create partition, size - 512 Mb (example), use as - EFI system partition, OK

    3. Create partition, size - remaining, use as ext4, mount point - /, OK

    4. Check how it looks like

    5. Install Now

Both above methods will result in GRUB installed on legacy and/or EFI systems. I have tried these methods.

1 Like

@Norbert_X (Norbert)

Thank you so much for the detail reply.

Now here's a something strange happened, in regards to what I thought (from the messages that were displayed, and these are in my imgur album) was a failed installation.

I just booted the same VM thinking I will format the drive with new partitioning scheme.

That "failed" installation booted just fine. Now before I remove this installation, and create a new one (with EFI system partition), do you need any logs from it?

Thanks again :slight_smile:

Imgur album:

1 Like

hi @norbert_x (Norbert)

While keeping that "failed" installation as it is (just in case if anyone interested in installation logs; please refer my earlier post), I created a new VM. Only this time I tried it with 3 partitions:
1, EFI system partition: 128 MB
2, EXT4 partition: 20 GB
3, SWAP partition 2 GB

installer still displayed the 2nd error I mentioned in my earlier post:

So then I created 4 partitions:
1, EFI system partition: 128 MB
2, Reserved BIOS boot area: 128 MB
3, EXT4 partition: 20 GB
4, SWAP partition 2 GB

and the installation went just fine, no more error messages. System rebooted OK too.

Thanks.

1 Like

@Norbert_X, sorry if I'm breaking chain of current discussion. I do not know where to ask, here or in the bug report. Regarding bug #1870213, what do you mean Alt+Shift hotkey does not work? I tested 20200808 build today (OEM install testsuite) and dual language works. Keyboard layout switchable with mouse click but not from keyboard with Alt+Shift. I don't know what is the default shortcut for keyboard layout switching. Tried Alt+Shift, Alt+Shift+k nothing. Alt+Mod4+k toggles on-board keyboard.

Alt+Shift by itself is working normally after manual set-up in mate-keyboard-properties on first login to 20.04 LTS or 20.10 (in this case).

The issue is that OEM config does not set any shortcut for layout switching. In previous versions it was set to Alt+Shift. This is why I raise this 1870213 issue.

On fresh normal install Ubiquity does not set (see 1870219 issue) this shortcut too. In previous versions it was set to Alt+Shift.