Upgrade from 16.04->16.10->17.04 menu & status bars missing

Hello, I have just done an upgrade on a little computer from 16.04 to 17.04. Operation run fine.
But at last when booting I have the desktop without menu and status bars. I am observing that mate-panel is running but display nothing. If I launch it as sudoer from terminal the menu and status bar appears and I have two instances of mate-panel in the process list. One that display nothing and the one launched by myself display the bars.
Have you any suggestions ?

Have you already tried deleting and recreating the menu and status bars? Does it then still happen?

I tried many time to kill it (kill -9 mate-panel) but it restart. It looks like the mate-panel launched by root doesn’t display the menus.

And the same problem occurs with additionally newly created panels (to confirm that it not only affects the default ones)?

Have you tried changing the panel layout in Mate Tweak?

I tested with mate-tweak and only Redmond and something weird, only redmond and cuppertino works.:scream:
And after a while the menu disappeared.
Any idea ?

Look in /usr/share/mate-panel/layouts to see if the other layout files are missing. If the other layout files are present you might check the permissions to be sure they are owned by root. The other files may be corrupted and need to be replaced, perhaps you can copy them from a live session, remembering to adjust the permissions if necessary.

One other thing you could do is to choose one of the layouts that is working, and modify it to your liking, and then save it in Mate Tweak. That should cause it to stay until you change it.

1 Like

Have you tried logging into the guest session to see how the panels react there?

A few links related to your problem:





I had the same problem. I also tried installing Solus Mate. Same problem missing panels after installing nvidia drivers and reboot. I found a solution to my problem by fluke. By pressing alt-f1 to access the menu, searched DISPLAY and disabled the 2nd monitor that is weirdly enabled by default. after pressing apply my panels are now visible and working. I hope this helps.

1 Like