Upgrade mate 20.04 LTS to 22.04 LTS - ‘Welcome’ and ‘software boutique not working

Hello All,
I have upgrade my laptop from MATE 20.04 LTS to 22.04 LTS of course it had some issue during the upgrade. First, The Welcome/Software boutique will not start either through the menu or CLI, so I uninstalled via the CLI, when I tried to reinstalled it failed and I received an error that keeps popping up everywhere. I get this error during an install for the Welcome program, updating the system via CLI, and the same failure happened during the Upgrade to 22.04 LTS.

See the error below:

Unpacking ubuntu-mate-welcome (18.10.0) ...
Setting up libreoffice-common (1:7.3.5-0ubuntu0.22.04.1) ...
rmdir: removing directory, '/usr/lib/libreoffice/share/registry'
rmdir: failed to remove '/usr/lib/libreoffice/share/registry': Directory not empty
dpkg: error processing package libreoffice-common (--configure):
installed libreoffice-common package post-installation script subprocess returned error exit status 1
Setting up ubuntu-mate-welcome (18.10.0) ...
dpkg: dependency problems prevent configuration of libreoffice-help-en-us:
libreoffice-help-en-us depends on libreoffice-common (>= 1:6.1.0~); however:
Package libreoffice-common is not configured yet.
libreoffice-help-en-us depends on libreoffice-l10n-en-us; however:
Package libreoffice-l10n-en-us is not installed.
Package libreoffice-common which provides libreoffice-l10n-en-us is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
dpkg: error processing package libreoffice-help-en-us (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libreoffice-help-common:
libreoffice-help-common depends on libreoffice-common; however:
Package libreoffice-common is not configured yet.

dpkg: error processing package libreoffice-help-common (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Processing triggers for man-db (2.10.2-1) ...
Errors were encountered while processing:
libreoffice-common
libreoffice-help-en-us
libreoffice-help-common
libdvd-pkg: Checking orig.tar integrity...
/usr/src/libdvd-pkg/libdvdcss_1.4.3.orig.tar.bz2: OK
libdvd-pkg: apt-get check failed, you may have broken packages. Aborting...
E: Sub-process /usr/bin/dpkg returned an error code (1)

I will post my system info below:

[email protected]:~$ inxi -Fxz
System:
  Kernel: 5.15.0-46-generic x86_64 bits: 64 compiler: gcc v: 11.2.0
    Desktop: MATE 1.26.0 Distro: Ubuntu 22.04.1 LTS (Jammy Jellyfish)
Machine:
  Type: Laptop System: Hewlett-Packard product: HP EliteBook Folio 9470m
    v: A1029D1102 serial: <superuser required>
  Mobo: Hewlett-Packard model: 18DF v: KBC Version 62.19
    serial: <superuser required> BIOS: Hewlett-Packard v: 68IBD Ver. F.69
    date: 02/13/2018
Battery:
  ID-1: BAT0 charge: 27.0 Wh (96.8%) condition: 27.9/27.9 Wh (100.0%)
    volts: 16.3 min: 14.8 model: Hewlett-Packard Primary status: N/A
  Device-1: hidpp_battery_0
    model: Logitech Marathon Mouse/Performance Plus M705
    charge: 55% (should be ignored) status: Discharging
CPU:
  Info: dual core model: Intel Core i5-3427U bits: 64 type: MT MCP
    arch: Ivy Bridge rev: 9 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 1143 high: 1787 min/max: 800/2800 cores: 1: 1787
    2: 1190 3: 798 4: 798 bogomips: 18358
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard
    driver: i915 v: kernel bus-ID: 00:02.0
  Device-2: Cheng Uei Precision Industry (Foxlink) HP HD Webcam [Fixed]
    type: USB driver: uvcvideo bus-ID: 1-1.3:4
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 22.0.5 direct render: Yes
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
  Sound Server-1: ALSA v: k5.15.0-46-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard
    driver: e1000e v: kernel port: 2080 bus-ID: 00:19.0
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel bus-ID: 03:00.0
  IF: wlo1 state: up mac: <filter>
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: <filter>
  IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Drives:
  Local Storage: total: 476.94 GiB used: 426.15 GiB (89.4%)
  ID-1: /dev/sda vendor: SanDisk model: SD6SB2M512G1022I size: 476.94 GiB
Partition:
  ID-1: / size: 468.38 GiB used: 426.15 GiB (91.0%) fs: ext4 dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile
Sensors:
  System Temperatures: cpu: 50.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 359 Uptime: 4h 6m Memory: 15.49 GiB used: 7.38 GiB (47.6%)
  Init: systemd runlevel: 5 Compilers: gcc: 11.2.0 Packages: 3457 Shell: Bash
  v: 5.1.16 inxi: 3.3.13

--
Thanks In Advance,
Mike

Hello Mike

In your situation I would do a fresh installation and restore my personal data from a backup. That's my best advice. :slightly_smiling_face:

1 Like

I have a similar issue with Software Boutique and Mate Welcome after upgrading to 22.04. The fact that they are snaps means that the upgrade process shouldn't affect their functioning at all. It's clearly a bug of some sort as all the other snaps on my system work fine. I'll post my error code and see if someone has a solution:

[Welcome] Starting in Software Boutique mode. 
/snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome:1837: DeprecationWarning: Gtk.Window.set_wmclass is deprecated
  w.set_wmclass('ubuntu-mate-welcome', 'ubuntu-mate-welcome')
/snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome:1842: DeprecationWarning: Gdk.Screen.get_height is deprecated
  if s.get_height() <= 600:
[Welcome] Snap detected. Using __VERSION__ 
[Welcome] Version: 22.04.0 
[Welcome] Application Ready. 
Traceback (most recent call last):
  File "/snap/ubuntu-mate-welcome/709/usr/bin/ubuntu-mate-welcome", line 1399, in _load_changed_cb
    app.current_page = uri.rsplit('/', 1)[1]
IndexError: list index out of range

Same error for both snaps. I'm not too discouraged though as this upgrade was much less painful than when I upgraded from 18.04 to 20.04. Had to do fresh install in the end. With all Ubuntu flavours, it takes about 3 months to get the system working how you want it to after an upgrade, so nothing new here :slight_smile: Like the new Yaru themes, they look really good!

This is what I am going to do. Thanks for your help.

Mike W.

Thanks for your input Nemo. I am going to "Nuke and Pave" my laptop.

--
Regards,
Mike W.

You're welcome Mike. I'm not going to nuke & pave because of 2 snap packages - I just removed those 2 packages. If the bug gets fixed at some stage, I'll re-install them. Upgraded my desktop PC from 20.04 to 22.04 and those 2 snaps work fine, so have no idea what's going on, since the setup on both systems is very similar :man_shrugging:

1 Like

exactly with me. Desktop they work, Laptop they don't work.

1 Like

My problem exactly, I just gave up, but thought about something I read eons ago. I reformatted the USB drive. I then reinstalled the ISO of Mate to the same drive and it worked. BTW: I also did a quick format to the HDD. Kinda like MAGIC. I did not question it, but went on my merry way. At 3:00AM I was getting tired. I believe in the install process it marks the hard drive some way because after looking at the install on another laptop it was larger on the newer install?? I keep getting the same error message over and over.

Hi @mhwittek ,

You're right: some people are reporting issues with the "Welcome" and "Software Boutique" not working in Ubuntu MATE 22.04 LTS ("Jammy Jellyfish"). I've found the following two related topics also here in the "Ubuntu MATE Community" Discourse discussion forums:

  • First topic / discussion started by user @randomdave about 4 months ago (on 26th April 2022):
  • Second topic / discussion started by user @mickee about 2 weeks ago (on 19th August 2022):

Two weeks ago (on 20th August 2022), I've participated in that second topic with what I found about this issue. Link to my post:

In that post of mine, I've pointed to the following Issue / Bug that was reported by @tmt (https://launchpad.net/~tallosho) on 21st June 2022:

You may want to click on the "This bug affects 6 people. Does this bug affect you? " link in that Launchpad bug web page (to add yourself to the list of affected users by that bug) and you may also want to add a comment in that page to report your experience about this bug.

For the record, I have upgraded a week ago from Ubuntu MATE 20.04.5 LTS ("Focal Fossa") to Ubuntu MATE 22.04.1 LTS ("Jammy Jellyfish") and the bug didn't happen / isn't happening to me, but it's obviously happening to you and other people.

I hope this helps, in some way :slight_smile:

3 Likes

Here's the solution as posted by Luca on the launchpad bug page for that issue:

In my case, I fixed it permanently by deleting the file

./local/share/mime/mime.cache

I just tried it on my laptop and it works! :slight_smile:

5 Likes

Worked for me. Egggzellent!

2 Likes

Hey Nemo,
Thanks again for the input. The information that you passed down by Luca worked for me. I just renamed the file with an extension ".bku", and it worked. I am not sure this a workaround or a permanent fix, but my Welcome screen now comes up either when I click the Welcome Icon, or when my computer starts up.

Just a side note, I did indeed "nuked & paved" my laptop again, and I noted that this issue came up with the Welcome window after I reinstalled my OS and after the first system update/upgrade. My guess there is an issue with one of the system updates. Thanks again sir! Two cigars for you. :100: :boom: :index_pointing_at_the_viewer: :nerd_face: :nerd_face:

--
Best,
Mike W.

Hello Ricmarques,
Thanks for the reply. I will stop over to the post "This bug affects 6 people. Does this bug affect you? ", and I will make a note too. Perhaps, it will help the developers. :+1:

--
Best,
Mike W.

1 Like

Glad to help you out Mike! That's why I wrote that I wouldn't "nuke & pave" my system over a trivial system bug related to a snap running in non-confinement mode. And lo and behold that solution/workaround is as trivial as hell. Hopefully, whatever is the system bug will be sorted out soon as more info is posted by people on the launchpad bug page.

There was a bug in 20.04 which meant you couldn't burn CDs or DVDs. A workaround was posted fairly quickly, but no idea if this bug was fixed in the end as I just implemented the work around. So far, the work around for this bug hasn't affected anything else on my system, so it's all good!

Thanks for the cigars, just send them to me in a private message - I prefer Davidoffs by the way :stuck_out_tongue_winking_eye:

2 Likes