VMware and USB audio broken in 17.1

After upgrading to 17.1 I am unable to use VMware 14 to run Windows 8.1. The error is inability to lock enough RAM. I have 12 Gb in the laptop, and 6 Gb is assigned to Windows 8.1. After a fresh boot I am able to launch the VM but within a few minutes, even without any other apps running, it shuts down, reporting not enough RAM. I heard from another user on VMware’s forum that it works in 17.1 Unity but not other flavors of 17.1.

Also, after going to 17.1 my USB audio device stopped functioning. This one is a real mystery because the system appears to be behaving exactly as before but no sound is coming out. There are some 3rd party drivers installed from a non-default repository. The device is working on another 17.1 system which has default audio settings—no custom tweaks to ALSA and Pulse conf, no 3rd party drivers.

This is feedback, in case it is helpful. I am waiting for 18.04 now. The big mistake I made was going down the rabbit hole of inter-LTS releases. I had a good, working install of 16.04, which was doing everything I needed. I should have left it the heck alone. If 18.04 works out of the box, or with a few quick tweaks, I will leave it the heck alone till 20.04 comes out.

Hi @Isaiah_Sellassie,

try changing your software sources download location to somewhere else and updating again, I use the “Main Server” myself, if yours is set to your country, try changing it to “Main” per the update guide linked below. It may or may not help you?:


Thanks Wolfman! Somehow my repo had switched to US servers. I switched it back to Main.

Hi @Isaiah_Sellassie,

is your problem solved now?. :smiley:

I’m afraid not, Wolfman. The VMware problem remains. The USB audio problem remains.

I also get, “Could not get repository information. Check your internet connection” but on a 2nd or 3rd try the error box is followed by the normal update window with updates listed, and updates install properly.

Hi @Isaiah_Sellassie,

have you considered using VirtualBox instead?. :smiley:

Yes. I have a Windows 7 VM that runs in Virtualbox. There are no problems with it. Having VMware is not a deal breaker for me personally. I can run the app I need in Win 7. Win 7 in Virtualbox cannot deliver HD video.

I used the VMware Windows 8 because it has much more video memory, so it was able to deliver HD video. I used to watch MLB games in it. Luckily MLB has now updated their web streaming architecture to support HTML5 so I am able to watch games in Firefox without the Flash plugin. The use case for Win 8 has expired.

I reported the feedback in case it is useful. I can live without VMware.

I don’t really have anything else for you, I would opt for VBox and stick with that if it works for you. :smiley:

Thank you, Wolfman! I appreciate your time and attention. Yes, Vbox is sufficient for my current purposes.

Not having my USB audio device is a deal breaker. If 18.04 does not fix that I will definitely return to Windows. Linux on the file server, where all data is stored and backed up to the cloud. And, Windows on the desktops.

1 Like

Hi @Isaiah_Sellassie,

do you happen to have an AMD CPU?, I ask because the link below states about installing the amd64microcode package in Ubuntu?.

https://askubuntu.com/questions/971938/no-usb-digital-sound-on-17-10-but-win-10-sound-is-ok?utm_medium=organic&utm_source=google_rich_qa&utm_campaign=google_rich_qa :smiley:

I am not sure if this is for both 32 and 64 bit versions of Ubuntu though?. Open a terminal (Ctrl + Alt + t) and paste the following command and then restart your system. ONLY INSTALL IF YOU HAVE A 64 BIT VERSION IF AT ALL UNSURE, DON’T DO IT!:

sudo apt install amd64microcode

There is also the Intel package should you have an Intel CPU which works with both 32 and 64 bit versions if you happen to have one of those!:

sudo apt install intel-microcode

I hope it helps!. :thumbsup:

Thanks Wolfman! Here is the output

“intel-microcode is already the newest version (3.20180312.0~ubuntu17.10.1).
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.”

So, that’s not it in my case.

Hi Isaiah,

I really have no idea for any further course of action, sorry!. :frowning:

I appreciate your time and attention, Wolfman! You represent what is best about the Linux community. Thank you, again.

Cron is broken, VMware is broken, USB audio is broken. All were working fine in 16.04, so I am counting on 18.04 to fix these. Caja is fragile, and Samba shares cannot be mounted automatically—these I have to live with.

Do you know of an image viewer program with more features than EoM and Shotwell? I want to be able to sort files by height and width. Windows Explorer can do this.

Hi Isaiah,

I don’t know of any app that would sort by size sorry!. :frowning:

I can really only suggest you upgrade to 18.04, it is almost due for final release but you safely install it now, I have been using it for weeks and don’t have any problems with it!. :thumbsup:

I am waiting on a replacement M.2 SSD to arrive from China, and then it’s 18.04, first testing on my secondary system, and then on the main workstation. In the old days we used to worry about Windows update breaking things, and now we worry about Linux update breaking things. :slight_smile:


You could try booting into an older kernel, it may be that the kernel updates have caused the problems?. :smiley:

I should have tried that indeed. Here is what has happened in the meanwhile. My SSD arrived. I dd copied the MBR and then rsync copied all the folders other than home to the new drive. I switched the boot drive in BIOS hoping for the best, but nope—blinking cursor, no Grub.

Anyway, I plugged in my USB optical drive and fired up 17.1 Live thinking I might as well separate my root and home folders now since I have Aptik backup to restore my custom apps and settings. Well, 17.1 installation failed and it offered to send a bug report, but desktop was dead—no mouse or keyboard input did anything. But, before that it had warned me that if I continue with UEFI installation other OSes may become unbootable.

Sure enough, the working 17.1 on another drive did indeed become unbootable—it starts out fine, showing the logo and scrolling dots, and then drops to [initramfs] prompt, and blinking cursor. After a few minutes I hard rebooted out, and tried installing 17.1 without booting up Live. This time it crashed while installing ‘efi-grub-amd-64’ (? something like that) – my Thinkpad is an Intel, so not sure why it wanted to install that.

I gave up and decided to give Windows 10 a spin. It installed fine, and is running now. I will burn 18.04 to a disk and install it on a 16Gb embedded SSD which had been doing swap duty before, and use the 120Gb SSD as home. I suppose dual boot is the sensible option for me. I can eliminate use of the Windows VMs. There is only one program I really need, and I use it intensively when I do, i.e. no multi tasking. So, switching over to Windows for a couple of hours at a time, once or twice a week, until this project is done.

That’s the story. You’ve been just great, Wolfman, thanks again! :slight_smile:

1 Like

Hi Isaiah,

as far as UEFI partitions go, see the partitioning guide and the part about UEFI at the bottom:

Let me know if I can be of any more assistance. :smiley:

I wish I had read that before I started an install of 16.04.4. I have aborted it now. Just so I understand it clearly — during partitioning I have to assign /boot/efi to the 100Mb FAT32 partition created by Windows 10? And, can I still install Grub to the MBR of the drive with Linux root? I would prefer to keep the 2 OS separate, i.e. switch boot drive by pressing F12 and choosing it during startup, rather than choosing OS from the Grub menu. Is that still possible?

Windows is on sdb, which is the current default boot drive. I want Linux on sdc and use sda as /home. What is the best, cleanest, safest way to dual boot with UEFI only?

Thanks again, man, you are priceless!

1 Like

Hi Isaiah,

resize one of your Linux partitions by a small amount (enough to accommodate the UEFI partition) and create a UEFI partition within that, it should help solve your problem?.

Use “Boot repair” to fix GRUB after you have created the partition!:


You should also find Boot Repair in “Welcome”?, (on the Live CD at least!!). :smiley: