File chooser "Save as" starts searching rather than letting me rename the file to be saved

When I'm on a web page, If I try to save a picture or file, the save as window opens and if I choose to rename the file at that time, it opens up and populates the search. So the only way to do this currently is to download with default actual( file name then open caja and rename there). Not liking this at all. Makes the process harder than it needs to be.

1 Like

It does not occur with 18.04. What version are you using?

@fixit7 I am using 22.04

This is what I get when I tried to same an image.

Are you getting something different?

I am using Firefox.

It works ok on 20.04 too.

Hi @mickee,

I can't confirm the issue. UM 22.04 / Google Chrome.

1 Like

@fixit7 I get that too, but if I try to change the save as name it starts searching and brings up the search box

It sounds like a bug.

Hi, @mickee.

I got a feeling of déjà vu while reading this post of yours :slight_smile: After a few searches, I've found that you had posted a similar message about a month ago (on 8th August 2022), also here in the "Ubuntu MATE Community" discussion forums:

In that other topic of yours, @Norbert_X has replied the folowing:

... and then, in that same reply, @Norbert_X has pointed to the 2 following bugs in Launchpad:

Does that help? :slight_smile:


Oh boy! A case of getting forgetful as I get older. Thanks for the reminder! I also now remember marking this bug as affects me. Thanks!

1 Like

I would recommend GTK+3 Classic.
May solve this problem


Try renaming the file while you are saving

So it shows the ppa to add and the update command but not mentioning name of file to install, at least I don't see it

There is no specific file to install.
You may see the changes in the behavior of the file chooser.

It still doing this after installing that PPA. But I still don't see how installing the PPA would correct this, or are you saying when I run sudo apt update it may update a file that is in that repo? Its been identified as a bug, so I guess I will have to wait for someone to look into it. Hopefully soon as its quite a big deal for me.

Why are you still questioning instead of doing what has to be done?

sudo add-apt-repository ppa:lah7/gtk3-classic
sudo apt-get update

and it works

1 Like

Hi, @mickee and @tatanka :slight_smile:

For the record, I have never tried "GTK+3 Classic" - - created by Luke Horwell (@lah7 here in the "Ubuntu MATE Community"), but I think that I can help here a little bit, even so.

I see that in the web page "GitHub - lah7/gtk3-classic: Patches to bring back a traditional experience for GTK+3" there are more specific instructions to install "GTK+3 Classic", specifically the following instructions:

" (...)



Ubuntu 20.04, 21.10, 22.04

These packages are based on the original gtk+3.0 package, with the version suffixed with ~classic.

To install, add the repository and upgrade your packages:

sudo add-apt-repository ppa:lah7/gtk3-classic
sudo apt dist-upgrade

Available for these architectures: amd64, arm64, armhf, i386, powerpc and ppc64el.

To restore the original GTK3, use ppa-purge to restore the packages from Ubuntu's repository:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:lah7/gtk3-classic

(...) "

I hope that helps :slight_smile: You may also want to read the following 2 related posts written by @lah7 here in the Ubuntu MATE Community:

1 Like

Thanks @tatanka I did that. It doesn't work for me. I will try the dist-upgrade which I didn't do (full-upgrade)

mysterious.... hope dist-upgrade will help you.

Best wishes

I have also installed gtk3-classic, upgraded, dist-upgraded, rebooted, and tested several times, but the issue remains.


1 Like

welcome! Thanks for confirming.