Fresh mate install and gui keeps crashing [video]

I have fresh install of Ubuntu MATE 22 on old notebook (hp 2740p) with 8gb ram.

I am relatively experienced user, but not much of Linux desktop.

I am getting this strange crash to the green octopus screen. Why!?

When a browser (Firefox or chrome tested) is open and something is typed into the url field, and the suggestion is selected, it crashes. First to the black screen. Than the green medusa. Then password. Then it goes back.

How can I fix this? Why is it unstable?

1 Like

Look into /var/log/syslog, there should be some info why the laptop is crashing.

1 Like

Welcome @yarmil to the community!

System log during crash is here:

Hi, @yarmil (Y A Mill) :slight_smile:

I've searched the web for the specifications ("specs") for hp 2740p ("HP EliteBook 2740p Tablet PC") and I see that it has an "Intel HD Graphics" as its "Graphics card" (specifications available, for instance, at

Well, here in the Ubuntu MATE Community, in another similar discussion - Ubuntu Mate 22.04 auto ending Sessions when I do something specific - the user @esan_br (Elias Andrade), that has a "Dell Latitude E6410" which also has an "Intel HD Graphics" as its Graphics card, solved the same issue that was happening to him (MATE crash that took him back to the login screen), in "Ubuntu MATE 22.04 LTS" ("Jammy Jellyfish") by:

1 - Creating a file "/etc/X11/xorg.conf.d/20-intel.conf"

2 - Putting the following content in that file:

Section "Device"
Identifier "Intel Graphics"
Driver "intel"
Option "TearFree" "true"

3 - And then rebooting the computer.

Link to that post from @esan_br that he wrote on 1st October 2022:

In that same discussion, the user @Ygor6889 (Ygor Oliveira Silva), that also has a computer with an "Intel HD Graphics" video card, says that @esanbr's solution worked for him as well:

So, @yarmil , I suggest that you try @esan_br's solution, see if it works for you and then reply again in this same topic where we are now, to tell if that solution also worked for you (or not).

By the way: there's also the following other related topic here in the Ubuntu MATE Community, started in September 2022, by @CitizenUnderdog (Jake Hansen):

In that topic, I posted the same solution here:

... and, as you may see, several users there replied to me, in that topic, saying that solution worked for them as well.

Meanwhile, I also found the following bug reported in Launchpad ("Bug #1976161 “Session restarts when opening Pluma or GitHub link...” : Bugs : Ubuntu MATE"). I suggest that you see if it is that specific bug that is happening to you and, if it is, I suggest that you mark that bug as also affecting you and add a comment in that bug web page:

I hope this reply of mine helps you. Good luck! :slight_smile: