Grub fatal failure Lenovo S205

Hi Pavlos, time ago I was trying yo install my lifestudio microsoft camera in a Mate 18.04 32 bits and you helped me succesfully and mentioned me to better use 64 bits system.
I did it with MATE 20.04 but during the fresh install I am getting the message that GRUB had a FATAL failure, after that my laptop is only running once I use the USB stick (like now)
Please hel me, I am sure iti not an unusual problem, but I do not have enough experience in Linux as to know how to solve it. Thanks

@LUXKAX I looked at the old post, you had a 32bit install on a Lenovo S205.

This time, did you use a 64bit iso? is the laptop dual boot (meaning is there a win7 install there)? if grub has a fatal failure, that's major incompatibility on the hardware. Maybe you can start a different post (eg. install 20.04 on a Lenovo S205) and hopefully we can figure out the issue.

Hi Pavlos, indeed this laptop is the same that was operating on Ubuntu 18.04 32 bits, that installation ran well, without problems, yes the ISO is the 64bit iso, windows is not present since I installed UM 18.04 32.
The USB stick try option is working well, I'm writting using it.
I read some suggestions about to delete all partition using GPARTED but I will not do it until an expert is confirming it. Currently GPARTED is showing the following:

Partition Name File system Size Flags
/dev/sda1 EFI System Partition Fat32 512.00MiB boot, esp
/dev/sda2 ext4 465.26GiB
unallocated unallocated 1.02MiB

Tomorrow I will create the new post. It is a Lennovo S205 AMD E450, 4GiB RAM

I answered on your other thread with a complete guide ( Installing 20.04 is a nightmare! Please assist? ), the following may also be of use to you?. :grinning:

Thanks for the generic cut & paste novel; but been there, read that and am not worried about losing any data.
The complete guide is a one-seize-does-not-fit-all. In a perfect world, it makes sense. But I just want SIMPLE - one O/S and one HDD with nothing else on it. And it's been partitions have been removed and then UM isntalled and it did run, but if I shut down, I have to re-install it again and NEVER shutdown, or Sleep/Hibernate).

Thanks for your concern.
s.

1 Like

I am not familiarized with Linux, I am starting to learn about it. I just need a UM i working to initiate myself in Linux.

I was using in this same laptop 18.04 32 bits, and the installation ran nice.

I also read that the grub installation problems may happen more usually in a 32bits environment, being less in 64 bits.

For installation purpose I have used a pendrive, prepared by RUFUS and also another one with UNEBUTIN.

I also tried the ZFS experimental mode.

In all the intends I got the same message "Executing 'grub-install /dev/sda' failed. This is a fatal error."

As this laptop was running UM 18.04 32 bits I assume it has to be a configuration issue.
I will only run UM in this laptop and do not need any information that is there, so it may be completely cleaned and a fresh UM installation is what I want.

By the way, the laptop is running smoothly with the live USB version.

I have read some articles about how to reinstall grub including Supergrub2 and Rescatux applications, may that apps solve the issue?

Please help... Thanks

since the laptop works with the live USB, install boot-repair hoping it will fix the boot issue. From the live USB, you can issue the following commands (all works in memory) and hopefully boot-repair will detect the disk drive and fix the boot issue.

sudo apt-add-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install boot-repair
boot-repair

Ok, I did it and got a boot repair window (as superuser) asking for Recommended Repair, I clicked it, after a while processing a new window appear requesting "Please enable a repository containing the [grub-efi-amd64-signed] packages in the software sources of Ubuntu 20.04 LTS (sda1). Then try again."
Additionally Firefox crashed, so I left it there and I'm writing from my other computer in the mean time.

Can you do, sudo grub-install /dev/sda then sudo update-grub

I had to cancel the previous process in order to type in the terminal

sudo grub-install /dev/sda answered :

grub-install: error : failed to get canonical path of ' /cow'

There is a process to fix the boot issue but I'm not good with all the details.

I suggest you try a fresh install again, it will create sda1 (/boot/efi) and sda2 (/) and hope this time it will be able to write grub to sda. I would also skip the ZFS for now, just get familiar with linux.

@LUXKAX from your live USB, pop a terminal and paste

[ -d /sys/firmware/efi ] && echo "EFI boot" || echo "Legacy boot"

I assume it will tell you, EFI boot (it checks if /sys/firmware/efi dir exists).

Next step is to find out what partitions you have on disk, I make the assumption here that /dev/sda1 points to /boot/efi and /dev/sda2 points to / (your root partition)

The following commands can be run from the live USB (one line at a time)
(these commands mount the root and boot partitions into /mnt, then execute chroot to activate the filesystem in sda2, and attempt to reinstall the package that boot-repair complained about.

sudo mkdir -p /mnt/boot/efi
sudo mount /dev/sda2 /mnt
sudo mount /dev/sda1 /mnt/boot/efi
for i in /dev /dev/pts /proc /sys; do sudo mount --bind $i /mnt$i; done
sudo chroot /mnt
sudo apt-get update
sudo apt-get install ubuntu-system-adjustments
apt install --reinstall grub-efi-amd64-signed
sudo os-prober
sudo update-grub
exit

Hope this helps.

Just to cut into the conversation, there has been "problems" with grub, relating to EFI boot for awhile, and there have been some bug reports filed, I've added myself to several, this one I believe is "current" https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/1863434/

I'm not a technical user, but I have had to revive my grub files several times in the last 6 months after running updates that were "upgrading" grub . . . . One thing that @pavlos_kairis I don't think mentioned is using SuperGrub2 iso to boot an install . . . having that burned to a DVD (or flash drive) has been very helpful for my revival efforts. Unfortunately in my case I have 5 linux distros and the "repair" grub tools didn't seem to work . . . but the data posted above, using chroot to get to "os-prober" . . . in my case getting to opensuse which seems to include "os-prober" in its yast bootloader app . . . does seem to work.

The question is, is grub being flagged to /efi/boot so that grub is being installed to the EFI partition? That has been another point of error for me in the past . . . but, once its in . . . then the question is what is happening to grub vis EFI booting and it seems like there might be some snafu in the tubes???

Thanks Pavlos, I followed your instructions, but at the third isntruction UM answered that mount point does not exist.

[email protected]:~$ [ -d /sys/firmware/efi ] && echo "EFI boot" || echo "Legacy boot"
EFI boot
[email protected]:~$ sudo mkdir -p /mnt/boot/efi
[email protected]:~$ sudo mount /dev/sda2 /mnt
[email protected]:~$ sudo mount /dev/sda1 /mnt/boot/efi
mount: /mnt/boot/efi: mount point does not exist.
[email protected]:~$ ^C

Additionally, what Ihave done in the mean time:

1 Tried to solve it using Supergrub2 without results,
2 After that I intended Rescatux also without results (maybe I do not know how to use them)
3 As UM18.04 32 bits installed without problems I intended to install UM 18.04 64 bits getting the same fatal fail as with UM 20.04 64b
4 I came back and installed again UM 18.04 32b, and the laptop works perfect
5 I tried to install a dual boot system including UM 20.04 64b, that installation fails as before, but also lost access to UM 18.04 32b.

Some information about UM 18.04 installation that may help to the analysis

GPARTED
Partition____files system___mounting point___size_______used______free______options
/dev/sda1____ext4_________ / _____________465.76 GiB__16.23 Gib__449.53 GiB__boot
unasigned___unasigned___________________1.02 Mib

Also during the dual boot failed installation (already installed UM 18.04 32b and adding UM 20.04 64b) the system shows:

Unit: SCS1 (0,0,0) (sda) - 500.1 GB ATA ST9500325AS
Ubuntu 18.01.4 LTS______________Ubuntu MATE
/dev/sda1 (ext4)_________________/dev/sda2 (ext4)
256.2 GB________________________243.9 GB

partition table of SCSI1 (0,0,0) (sda) modified,0,0)
will be formate as
partition #2 of SCSI1 (0,0,0) (sda) as ESP
partition#5 of SCSI1 (0,0,0) (sda) as ext4

Another issue I have captured is at the beginning of the USB drive boot
(it is vary fast, I am not sure if I captured everything)

do_IRQ : 1.55 No IRQ handler for vector
Initframs unpacking failed: Decoding failed
usb 1-1: device not accepting adress 2, error -110

Hi non_space, thanks for your reply, as you noted I'm fighting with my Lenovo S205 with an AMD 450 processor.
SuperGrub2 is not working, I downloaded it and installed it on a Live USB using Rufus, but it is not starting, the other application I have tried is Rescatux, it started but I can only get the first screen.

The bug reports is to technical for me, but as you said, the problem my be the EFI partition, searching for probles like this I got this old post
https://forums.lenovo.com/t5/Lenovo-U-and-S-Series-Notebooks/S205-Bios-Linux-compatible-when/td-p/563823 where in one of the replies I have found:

Betreff: S205 Bios Linux compatible when?

2011-10-18, 15:03 PM

Linux works fine on the S205.

I have Ubuntu 11.10 running on my S205 alone and use it for university. With Ubuntu, you need to use the 64-bit edition, make a MSDOS partition table with Gparted, and create a 2 GB "EFI Boot Partition" in Ubiquity (the installation tool).

It ran quite okay-ish with Ubuntu 11.04, but works wonderfully with 11.10. Here's a video I did half a year ago:

http://www.youtube.com/watch?v=ij9To78Wt3w

I will intend to do something like that, try to make a MSDOS partition table with Gparted, and create a 2 GB "EFI Boot Partition"
But as I believe that the EFI Boot Partition should be done during installation, I will try it using Rufus and/or Unetbootin, I will try with both

I suspect if you change your BIOS to legacy boot, you should be able to install any ubuntu in that mode. There will be no /boot/efi, just /dev/sda1 for your root ( / ) and maybe a swap partition. UEFI has/is causing a lot of boot issues on laptops.

As for the error you posted earlier, sudo mkdir -p /mnt/boot/efi will create those dirs if they don't exist. Later, when you try sudo mount /dev/sda1 /mnt/boot/efi and fails, means /dev/sda1 is not found (which is strange because earlier the system reported that it runs efi boot.)

1 Like

Ok, the issue is that I do not have the option in my "Phoenix SecureCore tiano Setup" BIOs 4BCN24WW,

However, investigating I have found the following help:

"Unlocked two hidden menus named "Advanced" and "AMD", that contain a bunch of settings - including UEFI boot preferences known to cause much confusion with this model in the past.

Model: Lenovo IdeaPad S205
Type: Phoenix SecureCore Tiano
BIOS: 4BCN24WW (version 24)

Instructions

  • Flash BIOS using Flash.bat
  • Enter the BIOS after flashing, go to "Configuration" and disable the setting "Hidden Page". Save settings, reboot, and you will see the new menus."

Unfortunately my Configuration screen is not including the Hidden Page option.

I will continue searching

What @pavlos_kairis is suggesting about skipping EFI may indeed be the best option, I don't know PC world. But looking at the GParted data you provided doesn't seem to show anything formatted or flagged as "EFI" . . . possibly why your console commands returned, "not found" . . . . But, for the most part "2GB" for EFI is extremely large, OSX sets it at 200MB, and OpenSUSE would like 300MB . . . so even 500MB would be quite large for the purpose.

I'm going to try to post a screenshot of one of my drives, so you can see "EFI boot Partition" in large letters . . . again, you might not, need it, if you can work around it.

So, as far as SuperGrub2 . . . you do have to find the file that fits your computer, I had an older version for my PPC computers and it also "didn't work" on my '12 Mac Pro . . . until I found the 64 bit???? iso. Also I use "mkusb" to make my flash drives . . . not sure about Rufus, but over the years Unetbootin has been said by others to "not be so good" . . . . You should be able to boot the flashdrive with SG2 and then select the filesystem and boot it . . . if installed grub is failing. Not sure why that wouldn't work out to at least test the filesystem installation.

You did check the shasum numbers on your 20.04 iso???

So, one final comment, if you can get a clean install of 18.04 that boots and runs . . . do that, and then try to change the "/etc/apt/sources.list" file in "nano" or text editor . . . changing the name of "bionic"??? whatever the name of 18.04 is to "focal"??? for the 20.04 . . . and then save that data and run, an "apt update && apt dist-upgrade" after that, and that should upgrade your installation preserving your formatting . . . and leaving you with 20.04.

One final final question, did you try to run your install as "install alongside" and just let the installer decide how it wants to format itself??? If it works you can look at it in GParted and see what it did???

Is mkusb available for windows?....
Yes, I checked the shasum numbers on my 20.04 iso
Regarding 18.04, it is the 32 bits version, may the change from bionic to focal work?
My install was "as is" having not changed anything. it is not installing, my only option is to run it without installation. In that case GPARTED is currently showing: