20.04 Display issues with AMD GPU

So I backed up all my vital data to my external from main workstation, and proceeded to move to 20.04 from bionic. This machine has an AMD RX560. Upon boot into live image, I experience a severe graphical bug/artifacting. I have experienced this issue on this same machine in the past, with Debian MATE.

A different machine, with Nvidia graphics, booted into 20.04 like a charm with same USB. It isn't a faulty .iso. It must be a hardware or driver related incompatibility. I was able to boot Lubuntu, and vanilla Ubuntu live environments with no problem, so it's definitely an issue with this machine regarding the MATE DE.

Versions 18.04,19.10, as well Debian 9 were free of the issue.
Debian Buster displays the same bug as MATE 20.04 on my hardware.

I'm using DVI -> DVI monitor. I dont have an HDMI monitor to test that.
Here is what I'm greeted with:

I really want to stick with MATE flavor on my main workstation, but it seems I'm stuck.
Thanks for your time and efforts.


Interesting one. I gave it a try on both Ubuntu Mate 20.04 and Xubuntu 20.04 on my AMD desktop PC (GPU is Radeon VII) and I can confirm the issue.
Also, it seems others have the same issue, there is a post confirming this on Xubuntu Facebook and Reddit pages, together with a fix.

I am going to test install and run the fix, will report back later.

1 Like

Quick update. I found a temporary workaround for Ubuntu MATE.

  1. Boot live ISO, select safe graphics. Complete installation and shut down.
  2. On first boot, Hit "Esc" key to show GRUB menu, then "e" to edit, insert nomodeset at the end of the line that starts with "linux /boot/vmlinuz...". Press F10 to boot.
  3. Login and open "MATE Tweak".
  4. Select the third item from left panel: "Windows".
  5. In the Window Manager , switch to "Marco (No compositor)".
  6. Reboot (nomodeset will not be persistent so next boot is normal graphics mode).
  7. Enjoy.

Please note this is a temporary workaround so we can keep using Ubuntu MATE until a permanent fix is found. Once that is done, we can switch back to "Marco (Adaptive compositor)".


Appreciate the updates and work-around.

I urge you to file bug reports on this issue so it can get visibility and so that the developers can get the additional information needed to work on the issue.


1 Like

Sure, glad to help. Here is the bug report:


Thanks for your info and all your hard work. Simple users like me go through some strange workarounds. I ended up switching monitors with my other machine to solve the issue. I will end up switching back in the near future because I prefer to work on the 16:10 screen. It fits my XP-Pen graphics tablet's aspect ratio.

I'm glad that it's a known bug and not my monitor or GPU. When I do attempt to switch I'll let you all know how it went.

1 Like

Please see this bug report: https://gitlab.freedesktop.org/xorg/driver/xf86-video-amdgpu/-/issues/10

I have a Lenovo Ideapad 130-15AST. So as not to bloat the thread I put the output of lshw in pastebin here:

The above picture is what the MATE 20.04 live USB boots to.
I first upgraded from 18.04 using do-release-upgrade. The result looked like the photo as well.
Then I reinstalled 18.04, upgraded to 19.10, which looked and performed normally. I then upgraded the 19.10 install to 20.04 with the same result as the photo.
I also tried with a different flash drive just to rule that out.

Then I made the live USB of the 20.04 image and booted it to what you see above.
I made a live USB of both Stock Ubuntu and Kubuntu 20.04 and both worked just fine.

Until I tried the other two flavors I was thinking it was system specific, but after they worked normally it seems to be a MATE specific issue with this system.

It appears to be only a display problem. The DE is completely unusable with the mouse, but I can launch a terminal and run commands, although the terminal is just as distorted as the photo above, so you can't see what you are typing or the resulting output.

Is there anything else I can try to troubleshoot this issue to determine if it's a problem with that laptop or something with MATE itself on this hardware configuration?


Same problem here on lenovo v110-15ast. Amd a6-9200 cpu and r4 graphic. Same issue on Xubuntu 20.04.
It's fine on mate & xubuntu 19.10 and other 20.04 ubuntu flavours (kde, budgie, gnome)

I went ahead and filed a bug report on this.


@CerebralNomad Try this work around in the terminal:

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "glx" --create

The xorg upstream fix is slated to be added in an SRU.

However, at this time it appears that this will be made available in the 20.04.1 release. :frowning_face:

This issue also effects Xubuntu and Ubuntu Studio.

1 Like

Do you have to typ this work arround after every reboot or once?

The settings should be retained.

1 Like

I solved my issue by navigating through the garbled GUI, like a point and click pro.
I hit the super key, typed in tweak, hit enter, then carefully made it down to "windows" tab, then selected Marco(No Compositor). It is possible to do it even with the stair step effect if you carefully estimate the location of the pointer.
Problem solved instantly.


the terminal command didn't work for me

Try what @starseed-pl posted above and see if that work around works for you.

Had this before, just wanted to report that the work arround didn't work for me

Unfortunately, none of the regular QA or Dev Team members has an AMD GPU to test this.

Thus we are forced to rely on user reports and reports from other flavors to help troubleshoot.

We appreciate all the reports and troubleshooting steps everyone is providing.

I'm having the same issue, my computer, a laptop Lenovo is unusable due to this problem.

Is there any way to fix it? : (