How to change the language settings in Ubuntu

language

#1

Hi,

to completely change your system language from one to another; go to Control Center > Personal > "Language Support" then click on Install/Remove languages, make sure that the only language in the list is the one you want, example: English. Take the tick out of any unwanted languages and leave only one tick in English!!.

This is my own guide using German as my example.

Open language support in the Systems Settings menu and click on "Install/Remove Languages" then put a tick in the box for German, at the same time, take out the tick for the English language:

Click on "Apply Changes" and let it do its thing, you will be asked for your password:

Now you will see in the main window that only "Deutsch" is showing in the list, click on "Apply System Wide", now go to "Regional Formats" (if not already showing) and select "Deutsch (Deutschland)" and enter your password again (if asked) then close the window and restart your PC:

When you restart your PC, you will/should be asked whether you want to change the names of your folders to the new default language, say yes and then all your system folders will change to the newly installed language, in this case "German":

Folder language didn't change!.

If your home folder language doesn't change; run the following terminal command (Ctrl + Alt + t) and manually delete the folders you don't want (MAKE SURE THAT THERE IS NOTHING YOU WANT/NEED IN THE FOLDERS BEFORE YOU DELETE THEM!):

LANG=C xdg-user-dirs-update --force ; cat ~/.config/user-dirs.dirs

You will also need to run Grub update to change the Grub menu otherwise it will stay in the original language that you first used during your initial install!:

sudo update-grub

Change language when you have more than one installed system language:

If you have more than one language installed and want to switch between them, open Control Center > Other > Language Support and then with a left pressed mouse click, push the chosen language up to the very top of the list and then on "Apply system-wide":

So it looks like this:

Now open "Regional Formats" and do the same by selecting your desired language from the drop-down menu, click on "Apply system-wide" then restart your system:

When you restart your PC, you will/should be asked whether you want to change the names of your folders to the new default language, say yes and then all your system folders will change to the newly installed language, in this case "German":

See this section above if it didn't change: "Folder language didn't change!."

Reset Ubuntu Locales Manually:

Make sure that you have installed your desired country locale files before you start doing the following!.

To manually reset your system locale should the above not have worked for you, you will need to make yourself "root", press Alt + F2, enter your password and then enter the following command:

gksudo caja (in Ubuntu Mate)

gksudo nautilus (in normal Ubuntu)

Enter your password and navigate through your home folder: File System > Etc > Default > Locale

You will now (may) have a file that looks like this, I will be using German for my example, you need to replace the appropriate lines (Lang & Language) with your desired country locale!.

LANG="en_GB.UTF-8"
LANGUAGE="en_GB:en_US:en"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"

In my example, you need to change the top two lines to look like this, edit/replace "en_EN" with "de_DE":

LANG="de_DE.UTF-8"
LANGUAGE="de_DE:de"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"

Once you have made your changes, click on "File" > "Save" close Pluma and restart your PC, your system should restart in the desired language and you will be asked to change the folder names which you should do!.

Please bear in mind that your "locale" file can differ from the examples above, here is a current snapshot of my English language system with German language support installed, you may notice that there are no references to German in this list!:

Set the system language via the terminal:

Open a terminal (Ctrl + Alt + t) and type the following commands to set your system language to the language you want (Replace the ending on the package names to your desired locale otherwise you will have a German system if you use the commands below!).

echo $LANG # show current system language

en_US.UTF-8 (result of above command)

Install your desired language with:

sudo apt-get install language-pack-de-base language-pack-de

Update your system language with:

sudo update-locale LANG=de_DE.UTF-8 LANGUAGE="de_DE:de"

Set the default locale with:

source /etc/default/locale

Show system language again:

echo $LANG # show current system language

de_DE.UTF-8# changed

Once you have done the above, you must still open the language support tool and make your desired changes there, then run:

sudo update-grub

and restart your PC!.

Info from here (with a few changes to the APT command!):

http://www.server-world.info/en/note?os=Ubuntu_14.04&p=locale

Using "localepurge":

If you are still having problems with language on your PC; install the package "localepurge" to rid your PC of all unwanted language packages!!. Select only the language package you need to keep during the installation of the package (localepurge), you need to make sure that all the different packages for the same language are marked if you have a language that is globally (more or less) different!!. (A good example is French as there is Swiss French; Belgium French and French!) (Another example is German as there is German, Swiss German, and last but not least; Austrian German!)

To install "localepurge" via the terminal; use the following command (Ctrl + Al + t):

sudo apt-get install localepurge

During the install process, you will be asked to select your language, (Only select ONE language!):

Click on "Forward" when you see this message:

See also:

https://help.ubuntu.com/community/Locale

If your language still doesn't change; you may need to open: Control Center > Hardware > Keyboard > Layouts and see if there is more than one language listed, if there is more than one, remove the one that doesn't correspond to your actual keyboard layout.

Please bear in mind that your system may require an extra locale to support your keyboard if it is different from the system language like it is on my computer! (English/German).

If you only want extra language support but still want your system in English, open Synaptic and type "libreoffice french" or whatever language packages you need and select and install the results that show up. This will add language support for Libreoffice so you can type in languages other than English!.

Keyboard input method system

For languages with complicated symbols like Chinese/Vietnamese/Japanese etc, it is recommended you set "Keyboard input method system" to "IBus".

There is also an IBus tool in: Control Center > Other > Ibus Preferences

Manual install via the terminal (Ctrl + Alt + t):

sudo apt-get install ibus

See also:


Language settings in 16.04
Typing in Thai, Ubuntu MATE 18.04?
Terminal keyboard layout problem
Change keyboard and keep it
Recovery mode language issue?
Application: gculator
[SOLVED] Any way to seperate date format and currency?
Language issues in UM 16.04 system clock time zone settings (Clock 1.12.2)
Language flag does not appear in the login window
Xinput broken for C and ISO-8859 locales
Not translation to spanish center control
Control Center is partially translated (in french)
Synapse and IBUS bug
Ubuntu MATE 16.10 just won't install correctly
Printing horrors - US Letter permanently selected
How to launch 'Text Entry' setting?
UK keyboard layout won't work
Problems typing Portuguese characters
Tips, Tutorials and Guides Index
Ubuntu 18.04 for the Raspberry Pi
Mate-panel sugest to better
#2

Excellent work Wolfman


#3

Thanks Steve,

please do me a favour and have a quick read through it to see if there is something that is not legible/understandable and let me know. :smiley:


#4

doesn’t apply system wide change the whole language of the OS?
I did it once and my system changed everything in Japanese.
:slight_smile:
Anyway good guide @wolfman !!


#5

Hi @mastahaze,

oddly enough it doesn’t change everything, your clock and currency settings are regulated by the 2nd tab (Regional Formats) which you also need to adjust if you want your system fully set to one language only!. :smiley: