Ubuntu MATE 20.04 LTS Beta Testing

Welcome to the Ubuntu MATE 20.04 Beta Testing thread. :bug:

This week begins the Ubuntu Beta Testing Week for 20.04 and thus is an appropriate time to get the Ubuntu MATE community involved in testing the beta. This is being done in conjunction with our fellow flavors. https://wiki.ubuntu.com/UbuntuFlavors

join-family

https://wiki.ubuntu.com/FocalFossa/ReleaseNotes

20.04 Focal Fossa is an LTS release and will be supported by Ubuntu MATE for 3 years so it's going to be with us for a while.

You can find the beta ISO here:

If you have a spare machine or a virtual machine you can help us test and let us know if there are any issues you encounter; the earlier we know about them the sooner we can address them.

Please take some time and read the Ubuntu MATE 20.04 Release Notes.

You can also upgrade to the developmental version on your system (make sure to backup first!).

To upgrade, press Alt + F2, and type:

update-manager -cd

Feedback on the upgrade process is very valuable and we would like to hear your experiences.

5 Likes

for my surprise everything went well like 99% work
But as always "Brisk menu" is there to make our day a sad day


unknown2
i will post more bugs as i found them

i have installed ubuntu mate 20.04 using update-manager -cd command and am using traditional green theme. I feel there is peculiar problem that i noticed first time in the theme.

The windows when maximised have a clear separation between title bar and toolbar but when unmaximised there is slight overlapping between the two.

unmaximised window

(please notice changes on border just below title bar)

I initially installed with the ZFS disk formatting and noticed these issues:

When I tried to install Minecraft from the software boutique I got this error.

Also, I am unable to get the Firefox menus to appear unless I hold down alt and press the character for a menu like alt-f for the File menu.

Update: I ended up reinstalling with a regular disk format and both of these issues no longer occur.

Upgrading from 19.10 using Alt + F2 upgrade-manager -cd
Upgrade Seemed to freeze at unpacking 110-libsratom-0-0_0.6.4-1_amd64.deb

[FIXED]
I'm having an issue with ubuntu-mate-welcome and software-boutique snaps in 20.04.

When running both (via Terminal) I get:
snap-confine has elevated permissions and is not confined but should be. Refusing to continue to avoid permission escalation attacks

Wasn't sure if I should just let you know here or if I should log on launchpad or snapcraft.io...

[UPDATE]
Apparently less than 10 minutes after writing this, their was an update for snapd released and after updating, these are fixed. I'll now check for updates prior to reporting an issue!

I have used Ubuntu MATE for several years now, but I have to say the 20.04 release has me very excited, the new website and improved welcome are top notch, and all the other improvements of 1.24 are great the only problem I have had is the indicator date time not working

1 Like

What exactly is not working @Bernie?

I've just installed Ubuntu MATE Beta 20-04 in vitualbox in Mint Mate 19.3
first off I went with auto login, but got a login loop whenever I tried to open a program. An old thread said choosing a password login fixed his problem, so I reinstalled choosing password login. No difference, still get a loginloop when trying to start a program.
I checked the shasum256 before installing and it was OK. Not sure if I've founs a bug, or I'm doing something wrong

The indicator date time crashes at every startup and won't restart I uploaded the crash somewhere on here, probably something simple but it's happening on both my 20.04 machine and my 19.10 machine, but only started recently on my 19.10 machine

What version of VIrtualBox do you use?
Do you have ran installation with restricted addons included (checked [x] Install third-party software for graphics and Wi-Fi hardware and additional media formats)?
It may be known Xorg/GStreamer bug, which is out of our responsibility.

Which application are you trying to start?
If it is Welcome and you have restricted addons enabled - apply method from other thread and then reboot VM.

Did you tried to reset mate-panel by doing right mouse click on it and selecting Reset Panel?

Thanks Norbet_X
I'm using
Version 5.2.34_Ubuntu r133883
Yes I ticked install third party software.
The login loop is now happening at login, seems to be getting worse each time I boot it. So tomorrow I'll try installing it again without ticking 3rd party software.

@Bernie, @Norbert_X

I found your crash report @Bernie. Similar problem was discussed here. It may be related to evolution calendar sync.

I'm testing Ubuntu MATE 20.04 and I saw problems with the icons. LiveUSB ok, but on Vbox and after installing give me this problem. (see picture)

I'm trying on a Macbook Air 6,2 Model Mac-7DF21CB3ED6977E5 v1.0

Another problem is when setting a city on MATE Weather applet, that one with the clock applet. It closes immediately, asking to reload or keep closed.

@ironfoot, @Norbert_X
I tried resetting the panel that did not work
Also I'm just using Google accounts and don't have anything on my calendars except what is default, but I'll look more into it when I have time

Not sure what happened here. Thought I'd replied last night, but this
morining on a different computer there's no sign of it. So I can't get
the v-box version, but later on I'll try reinstalling without
selecting 3rd party software

Hi all,

I'm just testing the 20.04 Beta now, I think it is generally pretty good from a typical MAC and Windows user perspective. I think I have found a bug in the Cupertino panel option for Libreoffice (all applications). The file menu in repeated twice at the top of the screen. This looks really bad and very unprofessional for a new users coming to the desktop.

Interestingly when I use Pantheon it doesn't occur.

Hopefully this can be resolved easily to improve the consistency of the user experience in one of the critical shipping applications?

Another quick question, in the Redmond layout is there an easy way to show the desktop? When using Windows at the bottom right hand corner there is a little area that you click to minimise all windows. Could this be incorporated in to the panel to make the layout more familiar to Windows users? In the screenshot below I would expect it to be to the right hand side of the power icon. This is probably a small change for someone to make but a nice quick paper-cut that would improve usability.

Missing_Minimise_Redmond

Thanks guys! It's been a little while since I have used MATE but it is great to see the progress you are all making. Particularly the work on the desktop layout I was advocating for around four years ago.
:smiley:

Finally, I might be doing something wrong here but is there away to use the lovely default theme and icons from Ubuntu (I think it is called Yaru)? Wouldn't it make sense that this is available by default on the ISO, but not necessarily the default used?

Does anyone also ses the benefit of there being themes on the ISO that more closely resemble the panel layouts? So you could use Yaru for Mutiny, something a little like Windows 10 for Redmond and 3 colour dots for Cupertino?

Cheers,

James

How can I stop Virtualbox going through a login loop whenever I view as 1920x1080 VBoxSGA?

I cannot get past the login screen without testing with display settings at SVGA 1440x900.

I would like to test without installing on hardware, first, then move to hardware.

Thanks